Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

The pull down menus in Firefox 4 disappear too quickly to be usable.

  • 20 răspunsuri
  • 173 au această problemă
  • 664 de vizualizări
  • Ultimul răspuns de neworder13

more options

When you hover over something from the Menu Bar, (File, Edit, etc.) the pull down menu appears but disappears immediately as you try to move the mouse to select something. You can't select anything. On the Menu Bar, if you hover over just the underscored letter the pull down stays.

On the bookmark toolbar the pull down just flashes and you can select nothing. No position of the mouse works. I use right click and open all in tabs frequently, and now that capability has disappeared.

Toate răspunsurile (20)

more options

I can confirm this as well in Linux Mint. It usually happens after extended browsing, reading manga. When this happens again I'll make a moving screen shot of it, to show the unwanted effects. Is there any other information you guys need for this bug?

Modificat în de FireFreak

more options

I have Win XP Pro and also have this problem. I did not have it with the last 3.XX update and for a day did not have the problem with 4.+. I got the issue after the last Windows Security updates (5 I installed today from the last 2 weeks). Maybe it is related in some way.

more options

I should add that when I right click on a link from a website to open in a tab, etc., those menus do not stay up either.

more options

You can start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes/Appearance).

  • Don't make any changes on the Safe mode start window.

See:

more options

The only Addons/Extensions I'm running are Shockwave, Java, and Adblock Plus 1.3.5.

more options

I can confirm this problem on Debian unstable 64bit. I'm using the firefox4-binary (amd64) from the ftp-repository on mozilla.org. I have had this problem since the early betas, which I've been using on Ubuntu 10.04 and 10.10 and it seems to appear regardless of any specific configuration, be it OS, architecture or plugins. The problem usually appears after a few hours of browsing, I couldn't observe any correlation with a specific event.

A workaround that I've found is to minimize/restore the browser window. After that, menus behave as expected (at least for a while).

more options

I have this problem. All the pulldown menus seem to randomly disappear and reappear when mousing over them (bookmarks, menus, recent browse history). I'm able to get things to work by knowing the layout of the pulldown. I.e. I know the top of the link right click menu is "Open in New Tab". So, even if the menu disappears/becomes transparent, I can still use the mouse to click that location and get a response. I tried some of the suggestions in this thread. Disabling all the addons didn't seem to help, but running in safe mode does.

more options

Here is a video of the issue.

http://www.youtube.com/watch?v=sRNscNVY1Nc

more options

I have the same problem. Try this:

Firefox -> Options -> Options -> Advanced Tab -> uncheck "Use hardware acceleration when available"

After doing this my menus draw normally and the browser still seems to run well. I guess we'll have to wait for hardware acceleration once they get the bugs out :)

Modificat în de NetMagi

more options

I have the same problem. However, I thought there might be a correlation between Thunderbird and Firefox. I usually have both open. Well the menu in Thunderbird was disappearing. I closed Firefox and the menu was fine. Later the reverse happened, Firefox menu was disappearing. Closed Thunderbird and menu is fine. Curious isn't it?

more options

I tried NetMagi's solution copied below:

Firefox -> Options -> Options -> uncheck "Use hardware acceleration when available"

and the problem has disappeared.
more options

glad to hear it worked for you as well!

more options

I have the same problem in Ubuntu, but it only seems to happen if I leave Firefox open and the screensaver activates. After that I am unable to use the menus as they disappear as soon as the mouse is moved. If I activate the menu but do not move the mouse, I can select options using the keyboard. Otherwise restarting Firefox fixes the problem.

more options

Unchecking "Use hardware acceleration when available" fixed it immediately for Ubuntu / Firefox 4.0 -- no restart was needed.

In Firefox 4.0 for Ubuntu / Linux, the check-box is at: Edit > Preferences > Advanced > Browsing

Edit: the problem reappeared. Just going to the Edit > Preferences dialog box fixed it. I suspect there is some internal state variable that is reset by initializing ANY dialog box. I'll test this the next time it happens. I think it has nothing to do with hardware acceleration, at least for me -- I've re-enabled it, and the drop-down menus are still working.

Modificat în de nadirali

more options

Try this:

Open any dialog-box from the menu-bar, using either: 1. ALT-key or CTRL-key combination, or 2. Using the down/up arrow keys, followed by <ENTER> when the desired item is highlighted.

Close the dialog-box.

That fixes it for me temporarily. I was fooled into thinking unchecking "Use hardware acceleration when available", when just opening that box and closing it, without checking or unchecking anything, still does it.

Modificat în de nadirali

more options

Way too weird...! I'm running two monitors, Win 7. The problem occurs only on one monitor (the home one). When I drag the Firefox window over to the other monitor, the drop-down's work just fine.......!!!!!!!!!!!!!!!!!????????????????????

Update: disabling hardware acceleration DOES make the drop-downs work OK on both monitors....at least for now.

Modificat în de little1406

more options

I am having the same problem and then some. I am seeing disappearing menus and jerky mousepointer in other apps as well and on the MS quicklaunch bar. If I shut down FF4 the problem goes away completely.

more options

I AM NOT A TECHIE. I DO NOT KNOW WHAT I AM DOING WITH SOME OF THE TIPS ABOVE AND DO NOT WANT TO SCREW ANYTHING UP. LIVE CHAT IS NEVER OPEN.

COULDN'T SIGN INTO FIREFOX. COULD NOT RESET PASSWORD. HAD TO RE-REGISTER WITH ANOTHER E MAIL.

CAN'T USE PULL DOWN MENU'S. CAN'T USE MANY WEB SITES BECAUSE OF THIS.

IF I DO NOT HEAR FROM YOU ALL TODAY I AM GOING BACK TO EXPLORE. 4.0 SUCKS. TOO MANY PROBLEMS

EMILY

Modificat în de emily.zavitz

more options

I am having this problem with Firefox 7 from Mozilla running on Debian Squeeze under Gnome/Compiz. Minimizing momentarily does fix it, but it continues to go wrong again.

more options

I am having this exact same problem with version 10.0.1 - What is strange is I have a two monitor setup and it works fine on monitor 1 but once I move the firefox window over to monitor 2 it has the issue.