Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable Popup Auto-Hide not working on Firefox 90.0 64 bit under Ubuntu 20.04

  • 1 răspuns
  • 1 are această problemă
  • 3 vizualizări
  • Ultimul răspuns de 2snh2jhmcbg8v4b

more options

I am unable to find the menu option under "Web Developer Tools" -> "..." drop down menu as described at the below page.

https://extensionworkshop.com/documentation/develop/debugging/#debugging-popups

Also manually changing the "about:config" properties related to "devtools.popup.disable_autohide" and "ui.popup.disable_autohide" appear to have no effect at stopping html popups from being hidden when selecting the web developer tools window.

Is anyone else able to make this work?

I found the following curious commit which makes it sound like it may have been disabled on purpose, but I'm uncertain.

https://git.progress-linux.org/packages/engywuck/firefox-esr/commit/browser/app?h=debian&id=a7c8db0d7d4a7493e340a0cd3a41da435ef45823

"author Daniel Baumann <daniel.baumann@progress-linux.org> 2021-03-11 04:07:20 +0000 committer Daniel Baumann <daniel.baumann@progress-linux.org> 2021-03-11 04:07:20 +0000 commit a7c8db0d7d4a7493e340a0cd3a41da435ef45823 (patch) tree c3d79096d0a92925e4d9a7878128ad775c4086b5 /browser/app"

+// Disable autohide for DevTools popups and tooltips. +// This is currently not exposed by any UI to avoid making +// about:devtools-toolbox tabs unusable by mistake. +pref("devtools.popup.disable_autohide", false);

Toate răspunsurile (1)

more options

I just want to be clear based on what I've read online I was under the impression this could be used when debugging websites to stop website popups from disappearing when you change to the inspector in Web Developer Tools. It however is appearing like there is some confusion about if this tool is supposed to only apply for plugin debugging or also websites. I'm not sure I really understand the end decision though.

https://bugzilla.mozilla.org/show_bug.cgi?id=1468896

It looks like based on this discussion pre version 60 it also worked for websites and then after version 60 it only worked for plugins? Although I'm not entirely clear.

Te-a ajutat?

Adresează o întrebare

Trebuie să te autentifici pentru a răspunde la postări. Te rugăm să deschizi o nouă întrebare dacă încă nu ai un cont.