Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

FF doing a DNS query for all the web links on our home page when the home page is displayed

  • 2 răspunsuri
  • 1 are această problemă
  • 51 de vizualizări
  • Ultimul răspuns de cor-el

more options

We have a simple HTML home page that has links to the sites we most visit. This is the default page that comes up when we start FF. For instance, the web site for CNBC financial news is coded in HTML like this:

  • <a href="http://www.cnbc.com/">CNBC</a>
  • All the web links are in lists in cells a multi-cell table. There are about 40 of these links in the home page.

    While debugging a network problem recently using wireshark, I noticed that when I opened this home page in FF, There was a storm of DNS queries for all of the web sites in the home page! None of the web links were clicked on, this happens when FF starts up and just displays the home page. The same thing is happening on Windows 7 and Linux.

    I consider this invasive and would like this activity to stop.

    Why is this happening? Does this "feature" have a name? How do I stop this from happening?

    Thanks, Ed

    Versions: Windows 7: 73.0.1 Centos Linux 7: 60.6.0ser

    We have a simple HTML home page that has links to the sites we most visit. This is the default page that comes up when we start FF. For instance, the web site for CNBC financial news is coded in HTML like this: <li><a href="http://www.cnbc.com/">CNBC</a></li> All the web links are in lists in cells a multi-cell table. There are about 40 of these links in the home page. While debugging a network problem recently using wireshark, I noticed that when I opened this home page in FF, There was a storm of DNS queries for all of the web sites in the home page! None of the web links were clicked on, this happens when FF starts up and just displays the home page. The same thing is happening on Windows 7 and Linux. I consider this invasive and would like this activity to stop. Why is this happening? Does this "feature" have a name? How do I stop this from happening? Thanks, Ed Versions: Windows 7: 73.0.1 Centos Linux 7: 60.6.0ser

    Soluție aleasă

    You can check the "network.dns.disablePrefetch" prefs on the about:config page.

    You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

    Citește acest răspuns în context 👍 1

    Toate răspunsurile (2)

    more options

    Is that "simple HTML home page" viewable by any web user? If so, please post the URL so that we can see that page.

    more options

    Soluție aleasă

    You can check the "network.dns.disablePrefetch" prefs on the about:config page.

    You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.