Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

WHY does firefox keep sucking down resources - nonstop - even when not visiting any websites?!

  • 3 răspunsuri
  • 1 are această problemă
  • 3 vizualizări
  • Ultimul răspuns de Shadow110

more options

TWIMC,

Firefox is broken!!

Using firefox 5902 with Win 7.

When my browser has been opened to my homepage (about:blank) and I am NOT visiting ANY websites (yet), Firefox should NOT be CONTINUOUSLY and ENDLESSLY sucking down more and more RAM!

You can check this SAME situation on your OWN PC! 1) Open Windows Task Manager, processes tab. 2) Set your homepage to "about:blank" 3) Open firefox and watch WTM as the firefox process(es) starts INCESSANTLY sucking down (and NEVER releasing ANY) RAM!!

This process will continue until firefox has devoured ALL of your RAM rendering your PC - NON-responsive - FORCING a power-down-restart!!

THE most expedient way to VIEW this type of crash is to visit/explore "www.msn.com". This same site is a great example one of THE most egregious sites for continuous, unrelenting RAM consumption - all the way to the point of an INEVITABLE PC crash!!!

NOTE: PROFESSIONAL programmers employ "memory-dump" aspects to their apps to release unnecessary RAM retention and thereby ensure compatibility for ALL users' machines.

What happened, Mozilla? Good help is TOO hard to find?!

MAYBE you SHOULD try this "AGES-OLD solution":

Try becoming "iconic" - "IF IT WORKS - DON'T FG FIX IT!!!!!!!!"

>:-(

Capturi de ecran atașate

Toate răspunsurile (3)

more options

HI, Firefox Volunteer Support found that interesting but not much help since we can not make changes to Firefox. If wanting to leave constructive comments please go to the 3Bar Menu and Click on Help then Submit Feedback and it will be looked at by a panel that can make changes.

It would have helped if you had told us the amount of ram it was using and how many processes were running.

As for your issue/s please go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Then please go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Try higher and go back down till find the sweet spot. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Video Card Errors : adapterDescription: ATI Radeon 2100 (Microsoft Corporation - WDDM) driverDate: 4-25-2009 u'HW_COMPOSITING'}, {u'status': u'failed', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'failed', u'message': u'Failed to acquire a D3D11 device', u'type': u'runtime'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'failed', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'failed', u'message': u'Failed to acquire a Direct3D 11 content device', u'type': u'runtime'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'default'}] u'Advanced Layers', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'available', u'message': u'Enabled for Windows 7 via user-preference', u'type': u'user'}, {u'status': u'unavailable', u'message': u'Requires D3D11', u'type': u'runtime'}], u'name': u'ADVANCED_LAYERS'}]}

Suggest Reinstall proper AMD drivers instead of Microsofts from 2009 as running 10 year old drivers is a large problem going to sites like MSN.com with high graphic/media content. https://support.amd.com/en-us/download

Separate Security Issue, please update : Flash 28.0 r0 Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Please let us know if this good help solved your issue or if need further assistance.

more options
more options

You may find that the Extended Release Version of Firefox is more suited for your system : 52.7.4esr. It will continue to get security updates until June 2018, and you can download and install it from this page:

Note : Legacy Extensions will be deleted or removed in any version update after June 2018.

Update Path : Firefox 52.9.0esr out on June 26 (same time as 60.1.0esr) will be the last major update for Firefox 52 ESR apart from any 52.9.x esr updates for security or allowed stability fixes.

Based on Quantum : Firefox 60.2.0esr will be out Aug 21 and Firefox 52 ESR will be EOL then. So people will have to upgrade to 60.2.0esr to keep getting security updates if they have not manually upgraded to 60.x.o ESR already. Firefox 60 ESR will require Windows 7, 8, 10.

You should make a backup of your Profile before going back and just because:

Please let us know if this solved your issue or if need further assistance.