Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

Tools Page Info Media tab missing

  • 2 răspunsuri
  • 1 are această problemă
  • 228 de vizualizări
  • Ultimul răspuns de SF_Frog

more options

For years I have used Tools->Page Info->Media to help me debug my HTML code when an image is missing or has other problems. Recently the Media tab is missing on SOME webpages, but not all. It's always worked on my website homepage, but no longer. This has been an intermittent problem for months, but seems solid today. What is going on?

For years I have used Tools->Page Info->Media to help me debug my HTML code when an image is missing or has other problems. Recently the Media tab is missing on SOME webpages, but not all. It's always worked on my website homepage, but no longer. This has been an intermittent problem for months, but seems solid today. What is going on?

Soluție aleasă

The webpage is actually the homepage for one of my one-man businesses, and it has plenty of graphics. I think that the Firefox internal code for page info has changed in the lat year or two because I don't remember this problem before that. I code in raw HTML and CSS with a bit of java thrown in. I think I have just resolved the problem in terms of finding a workaround.

I have a rather complex naming structure for the 4 small websites I've written, where only one primary domain exists, and the other domain names (to save money on hosting) are "aliases" of subdomains of the primary one. For example, if abcd.com is the primary domain, then efgh.com is an alias for subdomain efgh.abcd.com, which is structurally abcd.com/efgh/.

If I try to get page info for efgh.com/index.htm, I see no Media tab, but if I get page info for efgh.abcd.com/index.htm or abcd.com/efgh/index.htm, then I DO get the Media tab.

Problem (sort of) solved via a workaround.

Citește acest răspuns în context 👍 0

Toate răspunsurile (2)

more options

The Media tab only displays when actual media are found, which you can check by viewing a text-only page. Changes are (and I’m not sure) some optimizations have been applied in recent Firefox versions. For instance, the Activate plugins section in the Permissions panel is left out if the Flash plugin is not set to "Ask to activate" or "Always activate". This may be related, or an intended result of that change.

Therefor I assume there is something wrong (as in "undetected") with regard to any media when building the page. Would that be possible?

more options

Soluție aleasă

The webpage is actually the homepage for one of my one-man businesses, and it has plenty of graphics. I think that the Firefox internal code for page info has changed in the lat year or two because I don't remember this problem before that. I code in raw HTML and CSS with a bit of java thrown in. I think I have just resolved the problem in terms of finding a workaround.

I have a rather complex naming structure for the 4 small websites I've written, where only one primary domain exists, and the other domain names (to save money on hosting) are "aliases" of subdomains of the primary one. For example, if abcd.com is the primary domain, then efgh.com is an alias for subdomain efgh.abcd.com, which is structurally abcd.com/efgh/.

If I try to get page info for efgh.com/index.htm, I see no Media tab, but if I get page info for efgh.abcd.com/index.htm or abcd.com/efgh/index.htm, then I DO get the Media tab.

Problem (sort of) solved via a workaround.

Modificat în de SF_Frog