Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

Access to local files via URL is no longer possible

more options

As of Firefox 57, a replacement add-on for newTab-override is telling me "Access to local files via URL is no longer possible for extensions." It goes on to say something about Please consider using the „local file“ option or a local web server, for example via MAMP or XAMPP.

For my personal home page I have a local, handwritten piece of basic html that I use as file:///home/me/home.htm Is it going to be possible to feed that to these new Firefox extensions? Fortunately I can still set it as the home page, just not the page that comes up on a new tab.

Toate răspunsurile (3)

more options

The latest versions of New Tab Override have an import feature that allows you to import your current HTML file to the extension's local storage. If you modify the file often, this won't be very convenient, but if it remains the same for long periods of time, this probably will work for you. Firefox blocks some features of local pages imported this way, such as inline image links to local files, or use of local CSS and JS files.

To try this out, open the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then find New Tab Override on the right side and click its Options button. As shown in the attached screenshot, changing the first setting to local file shows a button you can use to import your page.

I didn't test it myself. Does it work for you?

more options

Uploading the personal home page as an extension per your instruction works to a point. Because no true javascript enable/disable exists short of the preference in about:config, I've added the following to my personal home page: ( < replaced with [ so that it doesn't actually run as html commands [script> document.write("[h2>[font color=\"red\">JAVASCRIPT IS ON![/font>[/h2>") [/script> [noscript>[/noscript> It works fine except when used by newtab override.

Modificat în de fuffberry

more options

Yes, that is a known limitation, that "in-line script" (which could mean any script in the document) is ignored. The author indicated that is a limitation of the current design of Firefox.