Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

why my browser(firefox) occupying too much RAM (over 900MB)

  • 1 răspuns
  • 2 au această problemă
  • 1 vizualizare
  • Ultimul răspuns de Happy112

more options

my browser draining my RAM. i don't know why!!! Its taking around 900MB+ RAM, i'm using default setting with only 2 additional add-ons one of them is Adblock pus and other one norton security toolbar. it also runs slow at start-up i mean really slow. please give some some solution to fix it.

Capturi de ecran atașate

Modificat în de akvishwas

Toate răspunsurile (1)

more options

Hi   !

Both AdBlock Plus and Norton Security Toolbar use a lot of RAM.

Instead of AdBlock Plus you might consider uBlock Origin :

https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/

As for Norton Security Toolbar : You're pretty safe with Windows' Defender and a safe browser like Firefox, but that's my personal opinion.

Also see : http://tech.firstpost.com/news-analysis/ex-mozilla-firefox-developer-says-anti-virus-software-does-more-harm-than-good-359798.html


Another reason could be Multi-process (e10s) :

If you are using e10s, you could turn it off as follows :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type and search for the preferences  :

browser.tabs.remote.autostart and set it's value to false (default)

browser.tabs.remote.autostart.2 and set it's value to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

You can check whether you have this feature turned on as follows : 3-bar menu button => ' ? ' button => Troubleshooting Information In the first table on the page, check the row for 'Multiprocess Windows' and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s - otherwise it should read : 0/1 (Disabled).


You could also try this preference : dom.ipc.processCount And set its value to '1' (if it's set to a higher value)