Caută ajutor

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Acest fir de discuție a fost arhivat. Adresează o întrebare nouă dacă ai nevoie de ajutor.

Firefox x64 installed alonside x32, but shows as x32 in "About" when run.

  • 6 răspunsuri
  • 2 au această problemă
  • 34 de vizualizări
  • Ultimul răspuns de James

more options

I've downloaded and installed 64 bit Firefox in a separate directory than my 32 bit version. When I run the 64 bit executable and check the "about" section, it shows as x32. In the troubleshooting section, it also shows as 32 bit.

Soluție aleasă

Make sure there is no Firefox instance running still when you start Firefox. Perhaps you had 32-bit Firefox still running when you tried to start 64-bit (Win64) version.

Citește acest răspuns în context 👍 1

Toate răspunsurile (6)

more options

Did you install the 64 bit version in the correct location?

  • (64 bit Windows;64 bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows;32 bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"
more options

Soluție aleasă

Make sure there is no Firefox instance running still when you start Firefox. Perhaps you had 32-bit Firefox still running when you tried to start 64-bit (Win64) version.

more options

Sorry for the delay in replying.

Yes to both your questions, cor-el. To James, I might have had the x32 running at the time, I can't recall.

The problem is resolved as of this morning, however. The only thing I did was restart the laptop(instead of just waking it from sleep) and run only the x64 version, and now Firefox shows correctly as x64.

I think James may be right, in that I can't run the two versions at the same time. They will show as whichever version I opened first?

Thanks for your help, and cheers.

more options

Note that you should use separate profiles for each Firefox version to avoid issues with corrupting the profile. See:

You can add -no-remote to the command line to open another Firefox instance with its own profile and run multiple Firefox instances simultaneously.

more options

I Will check those out, Cor-el.

Thanks.

more options

Note do not use the -no-remote switch with the default Firefox Profile.

The issue was you cannot run two or more instances of Firefox on same Profile.