Depanarea dificultatilor cu plugin-uri precum Flash sau Java pentru a repara cele mai comune probleme ale Firefox | Depanare

Depanarea dificultatilor cu plugin-uri precum Flash sau Java pentru a repara cele mai comune probleme ale Firefox

Voluntarii noștri lucrează la traducerea acestui articol. Până când va fi finalizată poate că versiunea în limba engleză a articolului vă poate ajuta.

If you are having problems with pages that use plugins (such as Flash, Java, and more) to display content, you may need to check to see whether a plugin is causing the problem.

Common problems caused by plugins include:

This article describes how to troubleshoot plugins. If you are having a problem with an extension or theme, see Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems. For general information on plugins, see Use plugins to play audio, video, games and more.

Determining if a plugin is the problem

You can selectively disable plugins while Firefox is running. If you suspect a certain plugin, disable it first, then test for your problem. If you don't know which plugin to disable:

  1. At the top of the Firefox window, click on the Firefox buttonOn the menu bar, click on the Tools menuAt the top of the Firefox window, click on the Tools menu, and then click Add-ons. The Add-ons Manager tab will open. Click the menu button New Fx Menu and choose Add-ons. The Add-ons Manager tab will open.

  2. In the Add-ons Manager tab, select the Plugins panel.In the Add-ons Manager tab, select the Plugins panel.
  3. Select a plugin in the list and then click its Disable button. Repeat this step for each plugin in the list, until all of them are disabled. You do not need to restart Firefox for the changes to take effect.
  4. Test for your problem. If it does not occur, go back to the Add-ons Manager tab and re-enable plugins one-by-one with the Enable button until you find which one causes your problem to occur.
  1. At the top of the Firefox window, click on the Firefox buttonOn the menu bar, click on the Tools menuAt the top of the Firefox window, click on the Tools menu, and then click Add-ons. The Add-ons Manager tab will open. Click the menu button New Fx Menu and choose Add-ons. The Add-ons Manager tab will open.

  2. In the Add-ons Manager tab, select the Plugins panel.In the Add-ons Manager tab, select the Plugins panel.
  3. Select a plugin in the list and then select Never Activate in its drop-down menu. Repeat this step for each plugin in the list, until all of them are disabled. You do not need to restart Firefox for the changes to take effect.
  4. Test for your problem. If it does not occur, go back to the Add-ons Manager tab and re-enable plugins one-by-one with the Always Activate drop-down menu until you find which one causes your problem to occur.

If you find that disabling a plugin fixes your problem, continue following the steps in this article.

Updating or re-installing your plugins

Many problems with plugins can be solved by updating to the latest version of the plugin. To check if any of your installed plugins are out of date, visit Mozilla's Plugin Check & Updates page.

If updating to the newest version of the plugin or reinstalling it does not fix the problem, you can leave it disabled.

Manually uninstalling a plugin

If you can't use an uninstaller program to remove a plugin, you can remove it manually:

  1. In the Location bar, type about:config and press EnterReturn.

    • The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.
  2. Search for the preference: plugin.expose_full_path.
  3. Double-click on the plugin.expose_full_path preference in the list to change the value to true.
  4. Enter about:plugins into the Location bar and press EnterReturn to display the About Plugins page.
  5. Each entry in the About Plugins page will have "File name:" followed by a path. Use Windows Explorer to navigateNavigate to the folder shown for the plugin you want to remove.
  6. Rename the file to add an X in front of the filename (for instance, npswf32 becomes Xnpswf32).
  7. Double-click on the plugin.expose_full_path preference in the list on the about:config page to change the value back to false to avoid exposing the plugin path to websites.

The plugin will be removed.

If you can't use an uninstaller program to remove a plugin, you can remove it manually:

  1. Type about:plugins into the Location bar and press EnterReturn to display the About Plugins page.
  2. Each entry in the About Plugins page will have "File name:" followed by the name of the plugin. You can inspect the contents of the "pluginreg.dat" file (with a text editor) in your Firefox profile folder to find the location for each plugin. Use Windows Explorer to navigateNavigate to the folder shown for the plugin you want to remove.
  3. Rename the file to add an X in front of the filename (for instance, npswf32 becomes Xnpswf32).

The plugin will be removed.

If you can't use an uninstaller program to remove a plugin, you can remove it manually:

  1. Type about:plugins into the Location bar and press EnterReturn to display the About Plugins page.
  2. Each entry in the About Plugins page will have "File:" and "Path:", showing the name and location of the plugin file. Use Windows Explorer to navigateNavigate to the folder shown for the plugin you want to remove.
  3. Rename the file to add an X in front of the filename (for instance, npswf32 becomes Xnpswf32).

The plugin will be removed.

Re-initializing the plugins database

In some cases, you may not be able to install or re-install a plugin. Re-initializing the plugins database may fix this problem:

  1. Open your profile folder:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  5. Delete the pluginreg.dat file.
  6. Open Firefox
  7. In the Location bar type about:plugins and press EnterReturn to bring up the Firefox plugins list.



Share this article: http://mzl.la/NYtGci

These fine people helped write this article: . You can help too - find out how.
Get support for another platform:
Customize this article

Firefox