Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

Login problems and duplicate cookies in Firefox 4.1 64-bit/Linux

  • 2 respostas
  • 6 têm este problema
  • 143 visualizações
  • Última resposta por tmstone835

more options

I am having a problem logging into a web site after upgrading to Firefox 4.x. My system runs OpenSuSE Linux 64-bit 11.2 and their site uses Microsoft IIS server. The browser accepts about 6 cookies from their server during the login process and it works fine using Google Chrome, Opera, and Firefox 3.x. Firefox 4.0 and 4.01 seem to create duplicate cookie entries but only one of the duplicates is valid. The other shows up but has no internal data. The invalid or corrupt cookie shows up first on the list when viewed from Preferences --> Privacy --> Remove Individual Cookies so it seems as if those get read back by the IIS host first which results in an invalid login error.

I have spoken to the site admin and they say that they have not changed anything on their side but they have seen this problem with both Firefox 4 and Safari and it is somehow related to how the browsers are accepting and storing cookies.

As a test, I tried logging in, then I deleted the invalid cookies so only the good cookies were showing. I tried logging in again and it worked. I checked my cookie cache and the bad cookies are there again but at least I am logged in. I also tried deleting all cookies related to their web site and all cookies in my cache which did not help. I even removed the cache database file to see if was corrupt but that did not help.

My suspicion is that Firefox 4.x has a defective mechanism for accepting and storing cookies or their IIS server has a defect that is now manifesting itself because Firefox 4.x has tighter standards. Either way, it is still a Firefox problem because it will be impossible and improbable that we can get all of the IIS servers in the world to fix their systems to work with Firefox.

After Googling this issue, it appears that I am not the only one experiencing this. Has anyone else seen this problem and, if so, what have you done to fix it?

Todas as respostas (2)

more options

You should update to OpenSUSE 11.3 or 11.4
Your OpenSUSE 11.2 version is no longer supported via updates.


Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove the Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete cookies.sqlite-journal and cookies.txt, if they exist, in the Profile Folder in case the file cookies.sqlite got corrupted.

more options

Thanks cor-el but I have tried all of the standard troubleshooting methods that you mentioned.