Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

Some unicode symbols not displaying in Firefox 4

  • 5 respostas
  • 33 têm este problema
  • 1 visualização
  • Última resposta por cor-el

more options

Upgraded to Firefox 4 (with a recent update to 4.0.1) and found that many unicode symbols that displayed in FF3.6.16 are simply not displaying now. No weird codes, no odd symbol replacements, just no longer showing.

http://en.wikipedia.org/wiki/Miscellaneous_Symbols displays some of what I'm talking about ... the "Definitions" section shows what the symbol is (with a span class of "Unicode"), but when I scroll down to the "Images" section where the symbols are used, the symbols do not show. This is what I'm seeing on my FF window: http://img101.imageshack.us/img101/2134/unicodeissue.png

I don't believe it's a computer setting (Windows 7, 64-bit) as I didn't change anything except switching to FF4. Chrome and IE8 displays the symbols correctly. I've tried meddling with the Character Encoding on FF4 but they still do not display. Help?

Upgraded to Firefox 4 (with a recent update to 4.0.1) and found that many unicode symbols that displayed in FF3.6.16 are simply not displaying now. No weird codes, no odd symbol replacements, just no longer showing. http://en.wikipedia.org/wiki/Miscellaneous_Symbols displays some of what I'm talking about ... the "Definitions" section shows what the symbol is (with a span class of "Unicode"), but when I scroll down to the "Images" section where the symbols are used, the symbols do not show. This is what I'm seeing on my FF window: http://img101.imageshack.us/img101/2134/unicodeissue.png I don't believe it's a computer setting (Windows 7, 64-bit) as I didn't change anything except switching to FF4. Chrome and IE8 displays the symbols correctly. I've tried meddling with the Character Encoding on FF4 but they still do not display. Help?

Modificado por Eryne a

Todas as respostas (5)

more options

Do you see them if you disable hardware acceleration?

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

Try to toggle some of the Boolean gfx prefs on the about:config page to see if disabling some features helps. Filter: gfx

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

more options

Both suggestions don't seem to be working. I tried restarting FF for each boolean change and disabling the hardware acceleration just to be sure, but the symbols still won't display.

more options

Do you have the Symbola font installed?

Does it help if you disable the system fonts and switch to a different default font?

  • Tools > Options > Content : Fonts & Colors > Advanced : [X] "Allow pages to choose their own fonts, instead of my selections above"

Firefox 4 is more demanding about fonts and may refuse to use a specific font.

Modificado por cor-el a

more options

Disabling the system fonts did not show a change.

I did not have the Symbola font installed ... tried installing it, but it only brought up the characters I wasn't able to see before (see my original image in the question above). The symbols that were displayed as squares and numbers now show the actual symbol, but the symbols which did not display are still not showing.

Modificado por Eryne a

more options

It still sounds to me that you have a font that is either corrupted or that Firefox 4 doesn't like or use for other reasons.

Did you try other fonts? You can also try to install the DejaVu font (also mentioned on the Alan Wood page) and see if setting that font as the default help to identify a font problem.