Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

Firefox on macOS hangs for a few seconds when a video stream with audio starts playing, when using bluetooth

  • 1 resposta
  • 0 têm este problema
  • 1 visualização
  • Última resposta por jfchevrette

more options

I've been dealing with this issue for a long time now, without finding any solution

On macOS, whenever I am using Bluetooth headphones (Sony XM4, Airpods Pro), videos will hang for a few seconds just as the video is starting. This happens again if I pause/unpause or if I seek forward/backward on a video. The video "spinning animation" will appear and it will take 2-3 seconds for the video to start. This happens immediately, even if I click pause/start fast (ie: this is not after some delay necessarily). Also, if I mute audio on the video, the issue does not manifest itself.

During the waiting, Firefox itself seem to be hanging: for instance if I click on an extension icon in the toolbar, nothing will happen until the video finally start playing and then the extension menu will open up

When using Google Meet or Zoom for instance, I sometimes have to wait up to 10 seconds or so before Bluetooth Audio/Microphone starts after I've joined a meeting.

The issue is not specific to these platforms: I experience the same issue on other platforms such as Facebook, dailymotion, vimeo, zoom. On Facebook, since videos start muted, I can see the videos start playing right away, and then if I unmute sound the video stops, and start again with sound after 3 seconds or so

The issue does NOT manifest itself when playing an audio-only stream: ex Soundcloud or local radio stations audio stream

Things I've tried and didn't help - Troubleshoot mode - Different Firefox profile - Different Firefox install - Restarting my system

This feels like Firefox/macOS is waiting for Bluetooth to activate, or something like that. I have a feeling this only happens for certain types of video/audio codecs but I am not sure how to validate that (ex: no issues on soundcloud, petron audio-only posts).

The problem is entirely non-existent when I'm using sound output that is not Bluetooth.

This does not happen with other browsers otherwise I wouldn't be posting here :)

macOS 14.5, M1 Macbook Pro

I've been dealing with this issue for a long time now, without finding any solution On macOS, whenever I am using Bluetooth headphones (Sony XM4, Airpods Pro), videos will hang for a few seconds just as the video is starting. This happens again if I pause/unpause or if I seek forward/backward on a video. The video "spinning animation" will appear and it will take 2-3 seconds for the video to start. This happens immediately, even if I click pause/start fast (ie: this is not after some delay necessarily). Also, if I mute audio on the video, the issue does not manifest itself. During the waiting, Firefox itself seem to be hanging: for instance if I click on an extension icon in the toolbar, nothing will happen until the video finally start playing and then the extension menu will open up When using Google Meet or Zoom for instance, I sometimes have to wait up to 10 seconds or so before Bluetooth Audio/Microphone starts after I've joined a meeting. The issue is not specific to these platforms: I experience the same issue on other platforms such as Facebook, dailymotion, vimeo, zoom. On Facebook, since videos start muted, I can see the videos start playing right away, and then if I unmute sound the video stops, and start again with sound after 3 seconds or so The issue does NOT manifest itself when playing an audio-only stream: ex Soundcloud or local radio stations audio stream Things I've tried and didn't help - Troubleshoot mode - Different Firefox profile - Different Firefox install - Restarting my system This feels like Firefox/macOS is waiting for Bluetooth to activate, or something like that. I have a feeling this only happens for certain types of video/audio codecs but I am not sure how to validate that (ex: no issues on soundcloud, petron audio-only posts). The problem is entirely non-existent when I'm using sound output that is not Bluetooth. This does not happen with other browsers otherwise I wouldn't be posting here :) macOS 14.5, M1 Macbook Pro

Todas as respostas (1)

more options

After reviewing the troubleshooting information which I attached to this question, I noticed there were Audio Drivers I did not recognize (namely Zoom, as I do not use Zoom anymore). I went ahead and did additional research on audio drivers and decided to remove the Zoom audio driver to see if that helped

I went ahead and removed /Library/Audio/Plug-Ins/HAL/ZoomAudioDevice.driver and rebooted. It did not help.

I thought maybe there are other interesting drivers or plugins in there, so I looked in /Library/Audio/Plug-Ins/HAL/ and saw one called ACE.driver

ACE.driver is a driver installed as part of SoundSource which I had installed a long time ago and have since disabled and removed from my system. Turns out that ACE driver was still on my system and was causing the delay described in my original post. After removing the ACE driver and rebooting my system the issue is completely gone!

I am not sure why the issue was only present in Firefox since this is a system-wide driver. It is also quite strange that this only happened with Bluetooth and not other types of audio output

Case closed! :)

Útil?

Colocar questão

Deve iniciar a sessão com a sua conta para responder às mensagens. Por favor, comece uma nova pergunta, se ainda não tiver uma conta.