Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

Pressing "Ctrl" opens the sidebar for some reason? How do I stop it?

  • 7 respostas
  • 0 têm este problema
  • 27 visualizações
  • Última resposta por Terry

more options

Within the last day or two, Firefox has started opening the sidebar whenever I press "ctrl", which has caused a lot of annoying misclicks and prevents me from using "ctrl+" functions (e.g. new tab, cut, copy, paste, etc.).

How do I disable the sidebar? The instructions at the support page titled "Use the Firefox Sidebar to access bookmarks, history and synced tabs", specifically the subsection titled "Toggle the Sidebar on and off" (https://support.mozilla.org/en-US/kb/use-firefox-sidebar-access-bookmarks-history-synced), are unhelpful at best and incomprehensible at worst.

This problem is incredibly frustrating, and has even impeded me writing this request for help, since I couldn't use the keyboard to copy+paste the article title and URL.

TL;DR Please help me (permanently?) disable the sidebar from appearing.

Within the last day or two, Firefox has started opening the sidebar whenever I press "ctrl", which has caused a lot of annoying misclicks and prevents me from using "ctrl+" functions (e.g. new tab, cut, copy, paste, etc.). How do I disable the sidebar? The instructions at the support page titled "Use the Firefox Sidebar to access bookmarks, history and synced tabs", specifically the subsection titled "Toggle the Sidebar on and off" (https://support.mozilla.org/en-US/kb/use-firefox-sidebar-access-bookmarks-history-synced), are unhelpful at best and incomprehensible at worst. This problem is incredibly frustrating, and has even impeded me writing this request for help, since I couldn't use the keyboard to copy+paste the article title and URL. TL;DR Please help me (permanently?) disable the sidebar from appearing.

Todas as respostas (7)

more options

The keyboard shortcut to toggle the sidebar is Ctrl+B, so it is weird that pressing only the Ctrl key opens it for you.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

I restarted Firefox in Troubleshoot Mode per your instructions. When I opened the Add-ons and Themes menu (ctrl-shift-A), I couldn't find a theme called "Default", but I disabled my theme, which enabled one called "System Theme - auto". The problem persists after all this.

more options

tankertuxbro, is it possible that a key on your keyboard might have become stuck? So the system thinks a key is being held down when it isn't?

Or do you use keyboard macros?

more options

That's a reasonable suggestion, but if that were the case, I think I'd have unwanted letters popping up everywhere (I don't). I routinely used keyboard macros until this issue popped up, which I immediately noticed. I don't think any keys are stuck.

more options

Not all the time a failing key can be multiple issues. So unless your verify the keys or keyboard work there's no other way to know.

more options

Is successfully typing on my keyboard not enough to verify that it works? None of the letters stick as I type this out; my keyboard doesn't give me any trouble with any other programs, only Mozilla Firefox. I remain able to use keyboard macros with other programs with no issue. Another detail I just noticed, which may be related: pressing "alt" causes a topbar to pop down similarly to how pressing "ctrl" causes the sidebar to pop out.

more options