X
Toque aqui para ir para a versão móvel do site.

Fórum de Apoio

Changing text selection colour from vile yellow of 59.0.2 to mellow blue of previous release

Publicadas

Prior to the 59.0 upgrade text selections on a page were a mellow blue colour. Then came 59.0 and selected text is a vile yellow. Can't find anything in about:config to revert this change to something better. Where do I undo this awful UXer decision and restore sanity when selecting text?

Prior to the 59.0 upgrade text selections on a page were a mellow blue colour. Then came 59.0 and selected text is a vile yellow. Can't find anything in about:config to revert this change to something better. Where do I undo this awful UXer decision and restore sanity when selecting text?

Solução escolhida

Pkshadow close but no cigar.

Preferences > Languages > Colors and "Override the colors specified by the page with your selections above" is the culprit. The setting was "Only with High Contrast themes" it should have been (and what it was before the 59.0.2 upgrade) "Never". I hate producers who think they know better than me as to what I want. Whoever flipped "Only with High Contrast themes" needs to stop playing around.

Ler esta resposta no contexto 0
Citação

Detalhes adicionais de sistema

Aplicação

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0

Mais informação

jscher2000
  • Top 10 Contributor
7530 soluções 61377 respostas

Hi Glimfeather, I'm still seeing white-on-blue selections on Windows 7, even on a dark background.

I wonder whether your black-on-yellow (I assume) selections are related to a color scheme picked up from MacOS? Are you aware of any customizations of your system's or your Firefox's color schemes?

Hi Glimfeather, I'm still seeing white-on-blue selections on Windows 7, even on a dark background. I wonder whether your black-on-yellow (I assume) selections are related to a color scheme picked up from MacOS? Are you aware of any customizations of your system's or your Firefox's color schemes?
Isto foi útil para si?
Citação

Proprietário da pergunta

No customiasations for any application or macOS. Prefer to get paid work done than waste time fiddling. Firefox has always been default theme. Only changes are ad blockers (AdBlockPlus, Ghostery) to expunge lies from advertisers and prevent exploitation of personal data by Cambridge Analytica and its ilk. The mellow blue should not have been forced onto an otherwise defaulted setup.

No customiasations for any application or macOS. Prefer to get paid work done than waste time fiddling. Firefox has always been default theme. Only changes are ad blockers (AdBlockPlus, Ghostery) to expunge lies from advertisers and prevent exploitation of personal data by Cambridge Analytica and its ilk. The mellow blue should not have been forced onto an otherwise defaulted setup.

Modificado por Glimfeather a

Isto foi útil para si?
Citação
Pkshadow
  • Top 10 Contributor
974 soluções 13128 respostas

Hi, so what happens please when you go to Options --> Language and Appearance and then Colors ? What is the setup use System Colors  ? If use System then Uncheck please. If not select the color you want for then links.

Please let us know if this solved your issue or if need further assistance.

Hi, so what happens please when you go to Options --> Language and Appearance and then Colors ? What is the setup use System Colors ? If use System then Uncheck please. If not select the color you want for then links. Please let us know if this solved your issue or if need further assistance.
Isto foi útil para si?
Citação

Solução escolhida

Pkshadow close but no cigar.

Preferences > Languages > Colors and "Override the colors specified by the page with your selections above" is the culprit. The setting was "Only with High Contrast themes" it should have been (and what it was before the 59.0.2 upgrade) "Never". I hate producers who think they know better than me as to what I want. Whoever flipped "Only with High Contrast themes" needs to stop playing around.

Pkshadow close but no cigar. Preferences > Languages > Colors and "Override the colors specified by the page with your selections above" is the culprit. The setting was "Only with High Contrast themes" it should have been (and what it was before the 59.0.2 upgrade) "Never". I hate producers who think they know better than me as to what I want. Whoever flipped "Only with High Contrast themes" needs to stop playing around.
Isto foi útil para si?
Citação
Pkshadow
  • Top 10 Contributor
974 soluções 13128 respostas

Ya, sorry forgot the instructions for getting to that is different in a Mac.

S as to what changed it no idea. Was not Firefox as defaults remain the same as always. It may have been a glitch in a update for Firefox or Mac or the update followed a Mac instruction for your default. If you have a setting in your Mac to use High Contrast it would have followed those instructions.

Anyway am glad you have found the issue.

Please select the Answer that was the Solution for your Issue (yous), Thanks

Ya, sorry forgot the instructions for getting to that is different in a Mac. S as to what changed it no idea. Was not Firefox as defaults remain the same as always. It may have been a glitch in a update for Firefox or Mac or the update followed a Mac instruction for your default. If you have a setting in your Mac to use High Contrast it would have followed those instructions. Anyway am glad you have found the issue. Please select the Answer that was the Solution for your Issue (yous), Thanks
Isto foi útil para si?
Citação
jscher2000
  • Top 10 Contributor
7530 soluções 61377 respostas

I think we can now conclude:

  • The problem is caused by Firefox 59 following your system theme
  • Setting Firefox to not to do that -- "Never" override page styles -- is the workaround

We may never know why there was loss of this setting during this particular update -- I assume it was an isolated issue because you likely would have mentioned if there was a bulk loss of settings as occurs in a Refresh.

I think we can now conclude: * The problem is caused by Firefox 59 following your system theme * Setting Firefox to not to do that -- "Never" override page styles -- is the workaround We may never know why there was loss of this setting during this particular update -- I assume it was an isolated issue because you likely would have mentioned if there was a bulk loss of settings as occurs in a Refresh.
Isto foi útil para si?
Citação
Colocar questão

Deve iniciar sessão com a sua conta para responder a mensagens. Por favor comece uma nova questão, se ainda não tiver uma conta.