O plugin do Adobe Flash encerrou abruptamente - Impedir que isto se repita | Resolução de problemas

O plugin do Adobe Flash encerrou abruptamente - Impedir que isto se repita

A mensagem "O plugin Adobe Flash encerrou abruptamente" é mostrada quando o plugin Flash para de funcionar de forma inesperada. Recarregar a página irá geralmente fazer com que o vídeo, jogo ou animação sejam novamente executados.

Plugin crash notification
Plugin crash notification Fx21

Se o plugin Flash continuar a encerrar abruptamente, atualizar o mesmo para a última versão do Flash poderá resolver o problema. Este artigo explica como atualizar o Flash bem como outras possíveis soluções.

Atualizar o Flash

A última versão do plugin Flash deverá ter uma performance melhor e encerrar menos vezes. Para verificar se o Flash está atualizado, visite a página de verificação de plugin da Mozilla . Se for preciso atualizar o Flash, instale a última versão manualmente, seguindo os passos abaixo.

  1. Visite a página de transferência do Flash Player da Adobe e transfira o ficheiro de instalação do Flash.
    Atenção: A página de transferência da Adobe pode incluir uma caixa de seleção de software opcional (como o Google Chrome ou o McAfee Security Scan) que é selecionada por omissão. Se não desmarcar a caixa de verificação antes da transferência, o software será instalado no teu computador quando abrir o pacote de instalação do Flash.
  2. Quando a transferência terminar, feche o Firefox.

    No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  3. Abra o ficheiro de instalação do Flash que transferiu e siga as instruções.
Nota: Se estiver a ter problemas com o instalador do Flash a partir da página de transferências da Adobe, pode utilizar esta ligação do assistente de instalação do Flash Player para transferir diretamente o assistente de instalação completo.
  1. Visite a página de transferência do Flash Player da Adobe e transfira o ficheiro de instalação do Flash.
  2. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  3. Abra o ficheiro que transferiu (por exemplo install_flash_player_osx_intel.dmg).
  4. No Finder, abra o Install Adobe Flash Player.app para executar o assistente de instalação e siga as instruções.
  1. Visite a página de transferência do Flash Player da Adobe.
  2. Quando solicitado, guarde o ficheiro (por exemplo install_flash_player_"version"_linux."processor".tar.gz).
  3. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  4. Abra uma janela de terminal (no Gnome, clique no menu Aplicações, selecione Acessórios e em seguida, selecione Terminal.)
  5. Na janela do Terminal, mude para o diretório onde guardou o ficheiro que transferiu (por exemplo cd /home/utilizador/Transferências).
  6. Faça a extração de libflashplayer.so do arquivo que transferiu tar -zxvf install_flash_player_"version"_linux."processor".tar.gz.
  7. Como o super utilizador, copie o arquivo extraído libflashplayer.so, para o sub-diretório plugins do seu diretório de instalação do Firefox. Por exemplo, se o Firefox está instalado em /usr/lib/mozilla, utilize o comando sudo cp libflashplayer.so /usr/lib/mozilla/plugins e, em seguida, digite a sua senha do super utilizador quando e se esta for solicitada.

    0a85171f1802a3b0d9f46ffb997ddc02-1260326970-447-1.png

Desativar aceleração de hardware no Flash

Muitos problemas relacionados com o Flash podem ser resolvidos ao desativar a aceleração de hardware nas definições de Flash Player (a página de ajuda do Flash Player - definições de visualização da Adobe tem mais detalhes). Para desativar a aceleração de hardware no Flash:

  1. Visitar Esta página de ajuda do Adobe Flash Player.
  2. Clique com o botão direito do ratoPressione a tecla Ctrl enquanto clica no logótipo do Flash Player nessa página, e clicar em Definições no menu de contexto. O ecrã de definição do Adobe Flash Player será apresentado.
  3. Clique no ícone no canto inferior esquerdo da janela de Definições do Adobe Flash Player para aplicar o painel Apresentação.
  4. Desmarque a opção Ativar a aceleração por hardware.

    fpSettings1.PNG
  5. Clique em Fechar para fechar a janela de Definições do Adobe Flash Player.
  6. Reinicie o Firefox.

Desativar o modo protegido do Flash

O modo protegido do Flash pode originar bloqueios ou falhas do plugin para alguns utilizadores. Para o desativar, consulte as instruções da Adobe sob o cabeçalho "Último recurso": Fóruns da Adobe: Como resolvo problemas no modo protegido do Flash Player no Firefox?

O modo protegido do Flash pode originar bloqueios ou falhas do plugin para alguns utilizadores. Para o desativar, siga estes passos:
Aviso: O modo protegido é uma funcionalidade de segurança da Adobe que está ativa por omissão. A desativação do modo protegido do Flash desativa uma proteção de segurança.
  1. Na barra de endereço, digite about:config e pressione EnterReturn.

    • A página de aviso about:config "A sua garantia não cobre isto!" pode aparecer. Pressione Serei cuidadoso, prometo!, para aceder à página do about:config.
  2. Pesquise dom.ipc.plugins.flash.disable-protected-mode na lista de preferências.
  3. Faça duplo clique na opção para alterar o seu valor de false para true. (Se a opção já se encontra a true, então o modo protegido do Flash já se encontra desativado.)
  4. Clique no botão do menu New Fx Menu e depois clique em Sair Close 29 para fechar completamente o Firefox, para que a alteração produza efeito.
  5. Reinicie o Firefox.

Desative o Modo Protegido do Flash. Consulte as instruções da Adobe sob o cabeçalho "Último Recurso": Fóruns da Adobe: Como resolvo problemas no modo protegido do Flash Player no Firefox?

O modo protegido do Flash pode originar bloqueios ou falhas do plugin para alguns utilizadores. Para o desativar, siga estes passos:
Aviso: O modo protegido é uma funcionalidade de segurança da Adobe que está ativa por omissão. A desativação do modo protegido do Flash desativa uma proteção de segurança.
  1. Na barra de endereço, digite about:config e pressione EnterReturn.

    • A página de aviso about:config "A sua garantia não cobre isto!" pode aparecer. Pressione Serei cuidadoso, prometo!, para aceder à página do about:config.
  2. Procure dom.ipc.plugins.flash.disable-protected-mode na lista de preferências.
  3. Faça duplo clique na opção para alterar o seu valor de false para true. (Se a opção já se encontra a true, então o modo protegido do Flash já se encontra desativado.)
  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

    para fechar completamente o Firefox, para que a alteração produza efeito.
  5. Reinicie o Firefox.
O modo protegido do Flash pode originar bloqueios ou falhas do plugin para alguns utilizadores. Para o desativar, siga estes passos:
Aviso: O modo protegido é uma funcionalidade de segurança da Adobe que está ativa por omissão. A desativação do modo protegido do Flash desativa uma proteção de segurança.
  1. No topo da janela do Firefox, clique no botão FirefoxNa barra de menu, clique no menu FerramentasNo topo da janela do Firefox, clique no menu Ferramentas e clique em Extras. O separador Gestor de extras será apresentado. Clique no botão do menu New Fx Menu e escolha Extras. O separador Gestor de extras será apresentado.

  2. No separador Gestor de extras, selecione o painel Plugins.
  3. Encontre Shockwave Flash na lista de plugins e clique no botão Opções .
  4. Desmarque Permitir modo protegido do Adobe Flash.
    Fx38-UI-AdobeFlash-protected-mode
    Nota: Para saber mais, consulte o artigo modo protegido do Adobe Flash no Firefox.
  5. Clique no botão do menu New Fx Menu e depois clique em Sair Close 29 para fechar completamente o Firefox, para que a alteração produza efeito.
  6. Reinicie o Firefox.

Outras soluções


Partilhar este artigo: http://mzl.la/1GL7JcP

Este artigo foi útil?

Por favor, aguarde...

Essas pessoas maravilhosas ajudaram a escrever este artigo: cesperanc, Y4zata. Você também pode ajudar - descubra como.
Obter apoio para outra plataforma:
Personalizar este artigo

Firefox