Pesquisar no site de suporte

Evite golpes de suporte. Nunca pedimos que você ligue ou envie uma mensagem de texto para um número de telefone, ou compartilhe informações pessoais. Denuncie atividades suspeitas usando a opção “Denunciar abuso”.

Learn More

Não consigo alterar a fonte padrão

  • 5 respostas
  • 11 têm este problema
  • 2374 visualizações
  • Última resposta de Fabricio Zuardi

more options

Pessoal, há alguns dias postei um problema que vinha ocorrendo com relação aos textos serem só em negrito. Consegui resolver o problema mas agora o firefox deixou de exibir os texto com a fonte segoe ui e passou para o times. Já mudei na janela de opções/conteúdo mas ele não reconhece. Está ativada a opção 'páginas podem usar outras fontes'. Posso colocar a fonte que quiser na opção 'fonte padrão' e o FF continua mostrando em times. Já agradeço quem puder ajudar!

Solução escolhida

Uma outra opção que é um pouco mais força bruta seria você criar um css customizado para o firefox.

Um modo de sobrescrever o estilo padrão do browser é criar um diretório de nome chrome dentro do diretório do seu perfil e depois criar um arquivo chamado userContent.css dentro deste diretório chrome.

Aí neste css vc pode sobrescrever quaisquer regras de CSS que vc desejar, por exemplo, poderia colocar:

   * {
     font-family: "segoe ui light", "segoe ui","Segoe UI";
     font-weight: 300;
   }

Para forçar a fonte padrão ser a Segoe UI…

É um modo meio avançado e perigoso de mexer no visual das páginas do seu Firefox, mas é uma alternativa…

Ler esta resposta 👍 2

Todas as respostas (5)

more options

Existem alguns bugs no Bugzilla(que é o bug tracker do projeto Firefox) sobre esta fonte:

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=segoe%20ui&list_id=6323410

Veja este comentário por exemplo:

https://bugzilla.mozilla.org/show_bug.cgi?id=835204#c2

Boris Zbarsky (:bz) 2013-01-27 19:19:59 PST

Your problem is that Windows has two different font subsystems: GDI and DirectWrite.

DirectWrite thinks this is a lighter-weight font in the "segoe ui" family.

GDI thinks it's a font in the "segoe ui light" family.

How a browser reacts here will depend on which font subsystem it's using.

Per spec, the DirectWrite behavior is actually the correct one, last I checked.

Talvez desabilitando a aceleração por hardware você consiga fazer o Firefox usar a versão GDI desta fonte. Por favor tente e avise aqui se deu certo.

more options

Solução escolhida

Uma outra opção que é um pouco mais força bruta seria você criar um css customizado para o firefox.

Um modo de sobrescrever o estilo padrão do browser é criar um diretório de nome chrome dentro do diretório do seu perfil e depois criar um arquivo chamado userContent.css dentro deste diretório chrome.

Aí neste css vc pode sobrescrever quaisquer regras de CSS que vc desejar, por exemplo, poderia colocar:

   * {
     font-family: "segoe ui light", "segoe ui","Segoe UI";
     font-weight: 300;
   }

Para forçar a fonte padrão ser a Segoe UI…

É um modo meio avançado e perigoso de mexer no visual das páginas do seu Firefox, mas é uma alternativa…

more options

Fczuardi, obrigado pelas respostas. Bom cara, eu procedi como especificado no link da aceleração da sua primeira resposta mas nada daquilo deu certo. Quanto a segundo opção, css, eu vou tentar mais tarde para ver se funciona e depois volto aqui pra postar o resultado. Vlw por enquanto!

more options

Então fczuardi, criei o arquivo css no diretorio do perfil e ai resolveu. Blz cara. Boa solução para quem está com o mesmo problema. Valeu mesmo!!

more options

Legal! Valeu por marcar como resolvido! :)