Pesquisar no site de suporte

Evite golpes de suporte. Nunca pedimos que você ligue ou envie uma mensagem de texto para um número de telefone, ou compartilhe informações pessoais. Denuncie atividades suspeitas usando a opção “Denunciar abuso”.

Learn More

Video autoplay blocking issue

  • 6 respostas
  • 3 têm este problema
  • 60 visualizações
  • Última resposta de zeroknight

more options

Autoplay media blocking does not work. I've tried to block autoplay on sites settings and also done this about:config fix without results.

   media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
   media.autoplay.blocking_policy = 2
   media.autoplay.allow-extension-background-pages = false
   media.autoplay.block-event.enabled = true '

Videos still start playing in some websites. I've noticed that when reloading the page, then autoplay blocking works.

Example: https://www.iltalehti.fi/formulat/a/35242327-7699-45a2-a1b5-75ff330a9d13 When i go to page first time, it shows on the left of address bar, that autoplay function is not even enabled (no autoplay block icon). When i reload/refresh the page, then it shows that autoplay is disabled and autoplay block is working properly (icon appears).

So it's only issue when visiting the page first time, if page is refreshed, no issues.

Autoplay media blocking does not work. I've tried to block autoplay on sites settings and also done this about:config fix without results. media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll] media.autoplay.blocking_policy = 2 media.autoplay.allow-extension-background-pages = false media.autoplay.block-event.enabled = true '''' Videos still start playing in some websites. I've noticed that when reloading the page, then autoplay blocking works. Example: https://www.iltalehti.fi/formulat/a/35242327-7699-45a2-a1b5-75ff330a9d13 When i go to page first time, it shows on the left of address bar, that autoplay function is not even enabled (no autoplay block icon). When i reload/refresh the page, then it shows that autoplay is disabled and autoplay block is working properly (icon appears). So it's only issue when visiting the page first time, if page is refreshed, no issues.
Capturas de tela anexadas

Todas as respostas (6)

more options

I suppose the last line contains a typo ( ').

Try setting this value also. media.block-autoplay-until-in-foreground = false

more options

Yes, it was a typo and was already set to: false. This issue is somehow related to page loading, because page refresh does correct it.

more options

Autoplay is blocked for me on your example site with those settings, regardless of navigation method.

The blocked autoplay icon only appears if something tries to autoplay. Animated images are not treated as playable media and will never be blocked.

Does it still happen in Troubleshoot Mode?

more options

This autoplay issue happens also in troublehoot mode. Only page refresh stops video autoplay.

I just noticed that the ink in my starting post (if i click the direct link) video autoblock works. But when i go example to: https://www.iltalehti.fi/ and click any news link, videos start autoplaying until i refresh the page.

Alterado por P X R I em

more options

Just noticed that direct link that i posted first, if i click the link, autoplay block does work.

If i go to https://www.iltalehti.fi/ and click any news link, then video autoplay block does not work. Blocking works only after page refresh.

This happens in many other sites as well.

Alterado por P X R I em

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.