Pesquisar no site de suporte

Evite golpes de suporte. Nunca pedimos que você ligue ou envie uma mensagem de texto para um número de telefone, ou compartilhe informações pessoais. Denuncie atividades suspeitas usando a opção “Denunciar abuso”.

Learn More

Spell Check Not Working

  • 6 respostas
  • 1 tem este problema
  • 15 visualizações
  • Última resposta de FredMcD

more options

layout.spellcheckDefault is set to 1 The "check your spelling as you type" check box is checked. I have an English (GB) language pack add on installed. When I left right click in a multiline text entry box, there's no option to select languages.

layout.spellcheckDefault is set to 1 The "check your spelling as you type" check box is checked. I have an English (GB) language pack add on installed. When I left right click in a multiline text entry box, there's no option to select languages.

Todas as respostas (6)

more options

Left-click is a command. Right-click for the options.

more options

Quote: I have an English (GB) language pack add on installed.

It seems you installed the en-GB language pack and not the en-GB dictionary. This is a misunderstanding we regularly see happen. Note that the en-GB Firefox version doesn't come with a dictionary and you need to install one yourself.

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

Alterado por cor-el em

more options

FredMcD said

Left-click is a command. Right-click for the options.

Sorry, I meant right-click, but it still doesn't give any language/spell-check options.

Alterado por eugbug1 em

more options

In an input box, like the Post A Reply box in the forum, do a right-click. What options are listed?


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

more options

FredMcD said

In an input box, like the Post A Reply box in the forum, do a right-click. What options are listed? Start Firefox using Troubleshoot(Safe) Mode {web link} A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Thanks Fred. The problem was that I was using an English language pack ad-on rather than a dictionary.

more options

I take it all is well now?

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.