Pesquisar no site de suporte

Evite golpes de suporte. Nunca pedimos que você ligue ou envie uma mensagem de texto para um número de telefone, ou compartilhe informações pessoais. Denuncie atividades suspeitas usando a opção “Denunciar abuso”.

Learn More

Problema com mecanismo de pesquisa: potencial problema de segurança

  • 1 resposta
  • 1 tem este problema
  • 14 visualizações
  • Última resposta de Luis Davi

more options

Boa noite! Então, estou tendo problemas em pesquisar termos no Google pela barra de pesquisa. O Firefox alega "Não conectou: Potencial problema de segurança", mas, dando uma lida nas informações do erro, percebo que há escrito:

[...] O Firefox não confia neste site porque ele usa um certificado que não é válido para www.google.com. O certificado só é válido para os seguintes nomes: www.google.com.br, *.google.com.br, google.com.br

E, então, mudei a url da barra de pesquisa de google.com (que o mecanismo de pesquisa adiciona automaticamente) para google.com.br e funcionou. Pois bem, quero mudar o mecanismo de pesquisa para que ele adicione o ".br" automaticamente, mas não consigo achar onde e nem como. É possível?

Grato.

Boa noite! Então, estou tendo problemas em pesquisar termos no Google pela barra de pesquisa. O Firefox alega "Não conectou: Potencial problema de segurança", mas, dando uma lida nas informações do erro, percebo que há escrito: ''[...] O Firefox não confia neste site porque ele usa um certificado que não é válido para www.google.com. O certificado só é válido para os seguintes nomes: www.google.com.br, *.google.com.br, google.com.br'' E, então, mudei a url da barra de pesquisa de google.com (que o mecanismo de pesquisa adiciona automaticamente) para google.com'''.br''' e funcionou. Pois bem, quero mudar o mecanismo de pesquisa para que ele adicione o ".br" automaticamente, mas não consigo achar onde e nem como. É possível? Grato.
Capturas de tela anexadas

Solução escolhida

Olá a todos

Me chamo Luis Davi, estou aqui para ajudar.

Bom, o problema que detectou uma ameça no google, pode vir do sistema de segurança, provavelmente seu sistema de segurança esta no modo rigoroso, então qualquer mera ameaça por menor que seja o firefox ira identificar e bloquer, sugiro você tentar por o sistema de segurança no modo "Normal", dessa forma:

  • Configurações>Privacidade e segurança>Selecione o modo normal

Está é apenas uma dica, caso não funcione me retorne para eu tentar ajudar novamente

Att, Luis Davi

Ler esta resposta 👍 1

Todas as respostas (2)

more options

Eu estou tendo problemas semelhantes aos teus com o http/https. A forma correta de configurar isso deveria ser pelo Google, mas eu editei um userscript do GreaseMonkey que eu tenho pra fazer isso pra você, redirecionar para o ".br". Para instalá-lo você precisa instalar o addon GreaseMonkey e criar um script, copiar e colar as linhas abaixo exatamente como estão. O script está comentado linha por linha (não testei mas acho que não tem erro, qualquer coisa abra o menu do GreaseMonkey e desative, depois me envie uma réplica que eu posso olhar):

 // ==UserScript==
 // @name         Google Redirect to .br
 // @version      1.0
 // @namespace    https://github.com/iacchus/userscripts
 // @description  Redirects www.google.com to www.google.com.br
 // @author       iacchus
 // @match        *://www.google.com/*
 // @grant        none
 // @run-at document-start
 // ==/UserScript==
 
 arg = ".br";
 
 host = window.location.hostname // set hostname to 'host', ie., "www.google.com" or "www.google.com.br"
 
 if(!host.includes(arg)) { // checks if hostname contains 'arg,' ie., ".br"
   // if not, executes this:
   path = window.location.pathname // set pathname to var 'path', ie., "/search"
   query = window.location.search // set query to var 'query', ie., "?q=my+query"
 
   new_host = host + arg; // adds '.br' to hostname
   new_href = new_host + path + query // recreates: "www.google.com.br" + "/search" + "?q=my+query"
   window.location.replace(new_href); // redirect to new address "www.google.com.br/search?q=my+query"
 }

Alterado por Kassius em

more options

Solução escolhida

Olá a todos

Me chamo Luis Davi, estou aqui para ajudar.

Bom, o problema que detectou uma ameça no google, pode vir do sistema de segurança, provavelmente seu sistema de segurança esta no modo rigoroso, então qualquer mera ameaça por menor que seja o firefox ira identificar e bloquer, sugiro você tentar por o sistema de segurança no modo "Normal", dessa forma:

  • Configurações>Privacidade e segurança>Selecione o modo normal

Está é apenas uma dica, caso não funcione me retorne para eu tentar ajudar novamente

Att, Luis Davi