Pesquisar no site de suporte

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Como faço para habilitar o funcionamento de certificado digital A3 instalado em token?

  • 3 respostas
  • 1 tem este problema
  • 13670 visualizações
  • Última resposta de Zilmar

more options

Não consigo utilizar o certificado digital em token em nenhum site que permita esse tipo de autenticação (eCAC, Banco do Brasil, etc), embora com o Internet Explorer seja possível. Não há instruções na Ajuda que orientem como habilitar este "Dispositivo de Segurança".

Solução escolhida

Infelizmente eu não tenho um token com esse certificado para testar, mas a versão ESR do Firefox ainda suporta plugins NPAPI.

O problema é que essa restrição de plugins NPAPI pelos maiores navegadores já foi feita há algum tempo, mas as aplicações não evoluíram...

De qualquer modo, ainda tem essa opção de usar o Firefox ESR.

Ler esta resposta 👍 0

Todas as respostas (3)

more options

Olá!

Se a aplicação depender do Java, não será possível utilizar. https://support.mozilla.org/pt-BR/kb/por-que-o-java-silverlight-adobe-acrobat-e-outros-

O que você pode tentar fazer é exportar o certificado e instalar no seu navegador.

more options

Obrigado pela resposta, Zilmar.

Estou ciente da questão das aplicações "NPAPI".

Pelo que li até o momento, não é possível exportar e instalar se o certificado for do tipo A3.

Foi pensada uma solução para isto? Porque se não for possível usar o Java, mataram todas as possibilidades de se usar token como autenticação nos navegadores mais modernos...

more options

Solução escolhida

Infelizmente eu não tenho um token com esse certificado para testar, mas a versão ESR do Firefox ainda suporta plugins NPAPI.

O problema é que essa restrição de plugins NPAPI pelos maiores navegadores já foi feita há algum tempo, mas as aplicações não evoluíram...

De qualquer modo, ainda tem essa opção de usar o Firefox ESR.