X
Toque aqui para ver a versão para dispositivos móveis desse site.

Fórum de suporte

Como faço para imprimir qualquer boleto ou página pelo Firefox?

Postado

Desde hoje quando fui tentar imprimir um boleto pelo Mozilla Firefox o mesmo apresentou na opção visualizar impressão 3 páginas em branco. Como eu tenho um programa que salva o arquivo para PDF e depois envia para o Desktop eu fiz este procedimento e o boleto foi salvo apenas com páginas em branco. Tentei imprimir outras páginas da web e o navegador ficou completamente travado sem responder nada. Após isso, tive que fechar o navegador e reiniciar o firefox. Acessei este site de vocês: https://support.mozilla.org/pt-BR/kb/solucione-problemas-de-impressao-no-firefox Fiz todos os procedimentos explicados e não resolveu nada. O que eu devo fazer para que volte a poder imprimir novamente pelo navegador firefox?

Obs.: Lembro que não posso restaurar meu perfil por completo já que meu firefox está personalizado a minha maneira e se eu fizer isso perderei todas as configurações que fiz e todas as extensões que uso atualmente e que estão funcionando perfeitamente.

Desde hoje quando fui tentar imprimir um boleto pelo Mozilla Firefox o mesmo apresentou na opção visualizar impressão 3 páginas em branco. Como eu tenho um programa que salva o arquivo para PDF e depois envia para o Desktop eu fiz este procedimento e o boleto foi salvo apenas com páginas em branco. Tentei imprimir outras páginas da web e o navegador ficou completamente travado sem responder nada. Após isso, tive que fechar o navegador e reiniciar o firefox. Acessei este site de vocês: https://support.mozilla.org/pt-BR/kb/solucione-problemas-de-impressao-no-firefox Fiz todos os procedimentos explicados e não resolveu nada. O que eu devo fazer para que volte a poder imprimir novamente pelo navegador firefox? Obs.: Lembro que não posso restaurar meu perfil por completo já que meu firefox está personalizado a minha maneira e se eu fizer isso perderei todas as configurações que fiz e todas as extensões que uso atualmente e que estão funcionando perfeitamente.

Solução escolhida

Olá!

Você poderia testar a funcionalidade iniciando o Windows em modo de segurança?

Outro teste interessante seria desinstalar sua impressora e ver se o problema persiste.

Eu utilizo aqui o Cute Writer, que é da Cute PDF e não tenho problemas.

Ler esta resposta 0

Detalhes avançados do sistema

Extensões instaladas

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint

Aplicativo

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Mais informações

Jhonatas Rodrigues 39 soluções 233 respostas

Olá,

Lamento pelo ocorrido, peço que execute alguns passos para podermos identificar o problema.

Execute o Firefox em Modo Seguro para verificar se o problema continua. O Modo Segurança do Firefox é um modo de solução de problemas que desliga temporariamente a aceleração de hardware, redefine algumas configurações, e desativa os complementos (extensões e temas).

Se o Firefox estiver aberto,' você pode reiniciar o Firefox no modo de segurança atravez do menu Ajuda:

  • Clique no menu New Fx Menu , depois em Help-29 e finalmente em and Reiniciar com extensões desativadas.

Se o problema não ocorrer no Modo Seguro, uma extensão, tema ou a aceleração de hardware pode estar causando o problema. Por favor, leia o artigo Solucione problemas com extensões, temas e aceleração de hardware para resolver problemas comuns do Firefox para determinar isso.

Após isso execute normalmente o que você faz para imprimir as páginas ou arquivos em pdf.

Caso não consiga visualizar o pdf no seu navegador para colocar pra imprimir, peço que siga os seguintes passos:

  • Clique no botão New Fx Menu e selecione Preferências….
  • Selecione o painel Aplicativos.
  • Digite pdf na barra de pesquisa.
  • Para cada tipo de conteúdo listado, clique no menu suspenso da coluna Ação.
  • Altere a seleção para outra ação, como a "Pré-visualização no Firefox" ou "Usar Pré-visualização".
  • Feche a janela de Preferências.

Aguardo retorno com os resultados.

Atenciosamente, Jhonatas Rodrigues

Olá, Lamento pelo ocorrido, peço que execute alguns passos para podermos identificar o problema. '''Execute o Firefox em Modo Seguro''' para verificar se o problema continua. O [[Troubleshoot Firefox issues using Safe Mode|Modo Segurança do Firefox]] é um modo de solução de problemas que desliga temporariamente a aceleração de hardware, redefine algumas configurações, e desativa os complementos (extensões e temas). ''Se o Firefox estiver aberto,''' você pode reiniciar o Firefox no modo de segurança atravez do menu Ajuda: *Clique no menu [[Image:New Fx Menu]], depois em [[Image:Help-29]] e finalmente em and ''Reiniciar com extensões desativadas''. '''''Se o problema não ocorrer no Modo Seguro''''', uma extensão, tema ou a aceleração de hardware pode estar causando o problema. Por favor, leia o artigo [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] para determinar isso. Após isso execute normalmente o que você faz para imprimir as páginas ou arquivos em pdf. Caso não consiga visualizar o pdf no seu navegador para colocar pra imprimir, peço que siga os seguintes passos: * Clique no botão [[Image:New Fx Menu]] e selecione '''Preferências'''…. * Selecione o painel '''Aplicativos'''. * Digite pdf na barra de pesquisa. * Para cada tipo de conteúdo listado, clique no menu suspenso da coluna '''Ação'''. * Altere a seleção para outra ação, como a "Pré-visualização no Firefox" ou "Usar Pré-visualização". * Feche a janela de Preferências. Aguardo retorno com os resultados. Atenciosamente, Jhonatas Rodrigues

Autor da pergunta

Abri o firefox pelo modo de segurança e o problema continua.

Eu tenho um backup do perfil antigo de abril deste ano. Tentei fazer numa máquina virtual o procedimento de criar este perfil antigo com o gerenciador de perfis.

Tentei usar este perfil antigo e tentar abrir o visualizar de impressão. Novamente travou o navegador firefox e tive que reiniciar o mesmo. No caso do boleto o arquivo até chega a abrir na visualização de impressão, mas somente aparecem páginas em branco.

Também tentei fazer aquele procedimento explicado no próprio site de ajuda do firefox de deletar as linhas que contém a palavra print dentro de pref.js. Este procedimento simplesmente detonou todo o perfil e também nas configurações do meu mouse dentro da máquina virtual.

Tive que sair imediatamente da máquina virtual.

Espero que vocês possam me ajudar aqui para resolver este problema de impressão com o firefox já que ele é meu navegador padrão e imprimo muitos arquivos diariamente para meu trabalho.

Não posso criar um novo perfil já que este atual já está todo personalizado desde o firefox versão 24. São muitos anos configurando a minha maneira e não quero perder tudo que criei dentro do meu perfil personalizado.

Portanto, quero saber o que fazer para que a impressora volte a funcionar normalmente dentro deste perfil do firefox.

Aguardo contato.

Abri o firefox pelo modo de segurança e o problema continua. Eu tenho um backup do perfil antigo de abril deste ano. Tentei fazer numa máquina virtual o procedimento de criar este perfil antigo com o gerenciador de perfis. Tentei usar este perfil antigo e tentar abrir o visualizar de impressão. Novamente travou o navegador firefox e tive que reiniciar o mesmo. No caso do boleto o arquivo até chega a abrir na visualização de impressão, mas somente aparecem páginas em branco. Também tentei fazer aquele procedimento explicado no próprio site de ajuda do firefox de deletar as linhas que contém a palavra print dentro de pref.js. Este procedimento simplesmente detonou todo o perfil e também nas configurações do meu mouse dentro da máquina virtual. Tive que sair imediatamente da máquina virtual. Espero que vocês possam me ajudar aqui para resolver este problema de impressão com o firefox já que ele é meu navegador padrão e imprimo muitos arquivos diariamente para meu trabalho. Não posso criar um novo perfil já que este atual já está todo personalizado desde o firefox versão 24. São muitos anos configurando a minha maneira e não quero perder tudo que criei dentro do meu perfil personalizado. Portanto, quero saber o que fazer para que a impressora volte a funcionar normalmente dentro deste perfil do firefox. Aguardo contato.

Alterado por glalla em

Jhonatas Rodrigues 39 soluções 233 respostas
Se o problema for mesmo de perfil vou ter que reinstalar tudo novamente e reconfigurar todo o firefox da forma que eu personalizei?

Caso seja necessário criar um novo perfil, você pode fazer um backup do seu antigo e copiar somente as informações que deseja manter, como:

  • Favoritos
  • Histórico
  • Cookies...
Eu tenho um backup do perfil antigo de abril deste ano. Será que pode resolver se eu reinstalar este perfil?

Pode ser uma alternativa, mas sugiro que crie uma copia do seu perfil atual, para caso não funcione ou crie um novo perfil e coloque os dados desse citado.

Depois preciso de orientações para saber como eu faço para salvar tudo que estava no computador dentro do perfil do firefox após o mês de abril até hoje. É possível salvar tudo como está agora e também voltar a poder usar a impressora?

Sugiro que use o Firefox Sync, irá lhe ajudar com isso Como configurar o Sync no meu computador? . Obs.: Lembrando que o Sync não é um serviço de backup de dados, é recomendado que continue a executar regularmente os backups de seus perfis Firefox .

Eu tenho uma máquina virtual com o Windows XP. De repente posso tentar primeiro fazer isto nesta máquina virtual para depois salvar na máquina principal com o windows 8.1. O que vocês acham desta minha sugestão?

Sim, você pode fazer isso apesar de ser um pouco mais trabalhoso. Na questão do novo perfil podemos manter o atual salvo em uma pasta a parte, acredito que seja mais simples.

Antes de mais algum passo, esse problema com o pdf ocorre sempre no mesmo site ?

Caso ocorra em diversos sites, você pode executar uma restauração do seu navegador, seguindo os passos deste artigo Restaurar o Firefox - redefina extensões e configurações e após isso restaurar o backup do seu perfil Recupere dados importantes de um perfil antigo . Aguardo retorno.

Atenciosamente, Jhonatas Rodrigues

<blockquote> Se o problema for mesmo de perfil vou ter que reinstalar tudo novamente e reconfigurar todo o firefox da forma que eu personalizei? </blockquote> Caso seja necessário criar um novo perfil, você pode fazer um backup do seu antigo e copiar somente as informações que deseja manter, como: *Favoritos *Histórico *Cookies... <blockquote> Eu tenho um backup do perfil antigo de abril deste ano. Será que pode resolver se eu reinstalar este perfil? </blockquote> Pode ser uma alternativa, mas sugiro que crie uma copia do seu perfil atual, para caso não funcione ou crie um novo perfil e coloque os dados desse citado. <blockquote> Depois preciso de orientações para saber como eu faço para salvar tudo que estava no computador dentro do perfil do firefox após o mês de abril até hoje. É possível salvar tudo como está agora e também voltar a poder usar a impressora? </blockquote> Sugiro que use o Firefox Sync, irá lhe ajudar com isso [[Como faço para configurar o Sync no meu computador?]] . Obs.: Lembrando que o Sync não é um serviço de backup de dados, é recomendado que continue a executar regularmente os [https://support.mozilla.org/pt-BR/kb/copia-e-restauracao-de-informacoes-perfis-firefox backups de seus perfis Firefox] . <blockquote> Eu tenho uma máquina virtual com o Windows XP. De repente posso tentar primeiro fazer isto nesta máquina virtual para depois salvar na máquina principal com o windows 8.1. O que vocês acham desta minha sugestão? </blockquote> Sim, você pode fazer isso apesar de ser um pouco mais trabalhoso. Na questão do novo perfil podemos manter o atual salvo em uma pasta a parte, acredito que seja mais simples. Antes de mais algum passo, esse problema com o pdf ocorre sempre no mesmo site ? Caso ocorra em diversos sites, você pode executar uma restauração do seu navegador, seguindo os passos deste artigo [[Restaurar o Firefox - redefinir complementos e configurações]] e após isso restaurar o backup do seu perfil [[Recuperando dados importantes de um perfil antigo]] . Aguardo retorno. Atenciosamente, Jhonatas Rodrigues

Autor da pergunta

Já fiz tudo o que você citou anteriormente. Claro que eu tinha o backup do meu perfil principal atualizado e voltei a colocá-lo novamente.

Infelizmente todos estes procedimentos não resolveram para mim.

Como já havia dito anteriormente, eu havia personalizado meu firefox desde a versão 24.0 e hoje já está na versão 50.0.

Foi um trabalho de anos para deixar do meu jeito e para fazer isto que você falou de criar um novo perfil do zero vou perder praticamente todas as configurações, dados e estas extensões abaixo. Veja tudo que tenho instalado para você entender melhor porque eu não quero mexer nestas configurações:

- Classic Theme Restorer; - Flagfox; - Google Translator for Firefox; - IDM Integration; - Open Profile Folder; - QuickFox Notes; - Speed Dial; - Tab Mix Plus; - YouTube MP3; - Português (pt-BR) Language Pack 50.0 - Português Brasileiro (Nova Ortografia) 47.20160418

Tudo isto está instalado e configurado a minha maneira no firefox, já que este é o único navegador que permite fazer toda esta personalização.

Sempre que fui trocando de PC, fazia constantes backup's deste perfil para nunca perdê-lo.

Meu Computador é de 64 Bits com o Windows 8.1 e eu fui fazer a besteira de uma vez ter instalado a versão do firefox para 64 Bits.

Esta personalização que eu tinha feito no Firefox era para computadores com 32 Bits. Quando passei para 64 Bits não houve problema.

Mas, depois disto o computador começou a ter muitos travamentos e me recomendaram voltar para o Firefox com 32 Bits.

A partir disto eu comecei a ter certos problemas, mas por sorte ainda tinha alguns backup's antigos antes da alteração para 64 Bits.

Eu já tentei usar o gerenciador de perfil no executar colocando firefox-p, mas esta função volta o firefox para um perfil novo e eu perco este perfil meu personalizado.

Será que talvez não teria uma maneira de mexer nas configurações criando algumas chaves usando o about:config ou então alguma extensão específica para a função de visualização da impressão?

Fico no aguardo de sua resposta.

Já fiz tudo o que você citou anteriormente. Claro que eu tinha o backup do meu perfil principal atualizado e voltei a colocá-lo novamente. Infelizmente todos estes procedimentos não resolveram para mim. Como já havia dito anteriormente, eu havia personalizado meu firefox desde a versão 24.0 e hoje já está na versão 50.0. Foi um trabalho de anos para deixar do meu jeito e para fazer isto que você falou de criar um novo perfil do zero vou perder praticamente todas as configurações, dados e estas extensões abaixo. Veja tudo que tenho instalado para você entender melhor porque eu não quero mexer nestas configurações: - Classic Theme Restorer; - Flagfox; - Google Translator for Firefox; - IDM Integration; - Open Profile Folder; - QuickFox Notes; - Speed Dial; - Tab Mix Plus; - YouTube MP3; - Português (pt-BR) Language Pack 50.0 - Português Brasileiro (Nova Ortografia) 47.20160418 Tudo isto está instalado e configurado a minha maneira no firefox, já que este é o único navegador que permite fazer toda esta personalização. Sempre que fui trocando de PC, fazia constantes backup's deste perfil para nunca perdê-lo. Meu Computador é de 64 Bits com o Windows 8.1 e eu fui fazer a besteira de uma vez ter instalado a versão do firefox para 64 Bits. Esta personalização que eu tinha feito no Firefox era para computadores com 32 Bits. Quando passei para 64 Bits não houve problema. Mas, depois disto o computador começou a ter muitos travamentos e me recomendaram voltar para o Firefox com 32 Bits. A partir disto eu comecei a ter certos problemas, mas por sorte ainda tinha alguns backup's antigos antes da alteração para 64 Bits. Eu já tentei usar o gerenciador de perfil no executar colocando firefox-p, mas esta função volta o firefox para um perfil novo e eu perco este perfil meu personalizado. Será que talvez não teria uma maneira de mexer nas configurações criando algumas chaves usando o about:config ou então alguma extensão específica para a função de visualização da impressão? Fico no aguardo de sua resposta.
Jhonatas Rodrigues 39 soluções 233 respostas

Olá,

Como eu tenho um programa que salva o arquivo para PDF e depois envia para o Desktop ...

Qual programa você utiliza ?

Precisamos de informações mais detalhadas a respeito do problema, para ajudar de uma forma mais direta, considerando que as soluções mais comuns não funcionaram.

São elas:

    • Use um dos seguintes métodos para abrir a página Dados para suporte:
    • Clique no menu New Fx Menu , depois em ajuda Help-29 e finalmente em Dados para suporte.
    • Digite about:support na barra de endereços do Firefox e pressione a tecla enter.
  1. Na parte de cima da página Dados para suporte, você verá um botão que diz "Copiar como texto". Clique nele.
  2. Agora, volte para a sua pergunta no fórum e clique com o botão direito do mouse na caixa de resposta e selecione Colar no menu de contexto para colar as informações na pergunta no fórum.

Atenciosamente, Jhonatas Rodrigues

Olá, <blockquote> Como eu tenho um programa que salva o arquivo para PDF e depois envia para o Desktop ... </blockquote> Qual programa você utiliza ? Precisamos de informações mais detalhadas a respeito do problema, para ajudar de uma forma mais direta, considerando que as soluções mais comuns não funcionaram. São elas: *O Crash Reporter ([[Mozilla Crash Reporter]] ) * Dados para suporte #* Use um dos seguintes métodos para abrir a página Dados para suporte: #* Clique no menu [[Image:New Fx Menu]], depois em ajuda [[Image:Help-29]] e finalmente em ''Dados para suporte''. #* Digite '''about:support''' na barra de endereços do Firefox e pressione a tecla enter. # Na parte de cima da página Dados para suporte, você verá um botão que diz "Copiar como texto". Clique nele. #Agora, volte para a sua pergunta no fórum e clique com o botão direito do mouse na caixa de resposta e selecione '''Colar''' no menu de contexto para colar as informações na pergunta no fórum. Atenciosamente, Jhonatas Rodrigues

Autor da pergunta

Olá,

Tive que postar a resposta em um arquivo de texto, pois não coube aqui.

Fiz uma tentativa com a extensão Print Edit para tentar usar o recurso de visualizar a impressão e o mesmo travou novamente.

O programa que geralmente usava antes de ocorrer este problema com o firefox para imprimir é o CutePDFWriter. Depois de tantos problemas ele não funcionou mais quando tentei salvar algum arquivo e enviar para o Desktop.

O anexo ficou muito grande e não coube na resposta. Tive que adicionar através de um link externo.

http://www.cjoint.com/c/FLyeOHgiRS3

Aguardo resposta.

Olá, Tive que postar a resposta em um arquivo de texto, pois não coube aqui. Fiz uma tentativa com a extensão Print Edit para tentar usar o recurso de visualizar a impressão e o mesmo travou novamente. O programa que geralmente usava antes de ocorrer este problema com o firefox para imprimir é o CutePDFWriter. Depois de tantos problemas ele não funcionou mais quando tentei salvar algum arquivo e enviar para o Desktop. O anexo ficou muito grande e não coube na resposta. Tive que adicionar através de um link externo. http://www.cjoint.com/c/FLyeOHgiRS3 Aguardo resposta.
Jhonatas Rodrigues 39 soluções 233 respostas

Olá, Desculpe a demora para responder essa questão. Olhando os logs, aparentemente o causador do problema é o cutePDF, você pode tentar solucionar da seguinte forma:

Desinstalar o cutePDF e Instalar o Adobe Acrobat Reader.

Após isso:

  • Clique no New Fx Menu e selecione Preferências….
  • Selecione o painel Aplicativos.
  • Digite "pdf" na barra de pesquisa.
  • Para cada tipo de conteúdo listado, clique no menu suspenso da coluna Ação.
  • Altere para outra ação, encontrando o "Adobe Acrobat Reader" e selecionando o mesmo.
  • Feche a janela de Preferências, as alterações serão salvas automaticamente.

Aguardo retorno.

Atenciosamente, Jhonatas Rodrigues

Olá, Desculpe a demora para responder essa questão. Olhando os logs, aparentemente o causador do problema é o cutePDF, você pode tentar solucionar da seguinte forma: Desinstalar o cutePDF e Instalar o [https://acrobat.adobe.com/br/pt/acrobat/pdf-reader.html Adobe Acrobat Reader]. Após isso: *Clique no [[Image:New Fx Menu]] e selecione '''Preferências'''…. *Selecione o painel '''Aplicativos'''. *Digite "pdf" na barra de pesquisa. *Para cada tipo de conteúdo listado, clique no menu suspenso da coluna Ação. *Altere para outra ação, encontrando o "Adobe Acrobat Reader" e selecionando o mesmo. *Feche a janela de Preferências, as alterações serão salvas automaticamente. Aguardo retorno. Atenciosamente, Jhonatas Rodrigues

Autor da pergunta

Olá,

Segui todos os passos pedidos:

Desinstalei o CutePDF e o SumatraPDF. Depois reiniciei o PC. Instalei o Adobe Acrobat Reader. Acessei a seção de aplicativos e deixei na opção para abrir com o Adobe Acrobat Reader (padrão).

Aí depois fiz os testes em várias páginas para tentar imprimir. Cliquei na barra de menus em arquivo/visualizar a impressão.

Quando abre esta opção a tela do navegador firefox fica completamente travada e nada responde. Sou obrigado a acessar o gerenciador de tarefas para conseguir fechar o navegador.

Portanto, acredito que esta opção sugerida não resolveu o problema.

O que eu faço agora?

Olá, Segui todos os passos pedidos: Desinstalei o CutePDF e o SumatraPDF. Depois reiniciei o PC. Instalei o Adobe Acrobat Reader. Acessei a seção de aplicativos e deixei na opção para abrir com o Adobe Acrobat Reader (padrão). Aí depois fiz os testes em várias páginas para tentar imprimir. Cliquei na barra de menus em arquivo/visualizar a impressão. Quando abre esta opção a tela do navegador firefox fica completamente travada e nada responde. Sou obrigado a acessar o gerenciador de tarefas para conseguir fechar o navegador. Portanto, acredito que esta opção sugerida não resolveu o problema. O que eu faço agora?
Fabio Beneditto
  • Moderator
38 soluções 269 respostas

Olá

Coisa mais simples: esses dois campos estão marcados na janela de impressão?

(imagem anexo)

Olá Coisa mais simples: esses dois campos estão marcados na janela de impressão? (imagem anexo)

Autor da pergunta

Fabio,

Não tenho como saber pois quando clico em visualizar impressão o firefox trava completamente.

Ele não me deixa justamente entrar nesta tela que você me enviou em anexo.

Isto ocorre em qualquer arquivo ou página dentro do firefox.

Fabio, Não tenho como saber pois quando clico em visualizar impressão o firefox trava completamente. Ele não me deixa justamente entrar nesta tela que você me enviou em anexo. Isto ocorre em qualquer arquivo ou página dentro do firefox.
Samuel Santos
  • Moderator
81 soluções 870 respostas

Olá! Pode ser persistência minha, mas já tentou criar um novo perfil e verificar se o problema ainda ocorre?

  • Lembre-se: Você pode criar quantos perfis quiser e manter os antigos. Criar perfil ajuda a ter mais controle das personalizações do seu Firefox e ter privacidade de uso para cada tipo de usuário, assim, cada usuário pode usar seu perfil customizado e alternar entre elas a qualquer momento. Criar um perfil zerado (padrão) ajuda a identificar possíveis problemas com personalização, dentre outros.
Olá! Pode ser persistência minha, mas já tentou criar um novo perfil e verificar se o problema ainda ocorre? * Lembre-se: Você pode criar quantos perfis quiser e manter os antigos. Criar perfil ajuda a ter mais controle das personalizações do seu Firefox e ter privacidade de uso para cada tipo de usuário, assim, cada usuário pode usar seu perfil customizado e alternar entre elas a qualquer momento. Criar um perfil zerado (padrão) ajuda a identificar possíveis problemas com personalização, dentre outros.

Autor da pergunta

Eu já tentei criar um perfil do zero usando o gerenciador de perfis através do comando firefox -p, mas o próprio firefox não me deixa mais criar qualquer perfil novo. Só dá para usar o atual que tenho.

Eu não queria apagar este meu perfil atual devido ter personalizado ele por mais de 9 anos.

Como já citei acima tem muitos complementos que uso diariamente para o meu trabalho e não posso apagar.

Pesquisando na internet através do google eu fiz o seguinte.

Criei uma nova conta de usuário no windows sem ser administrador. Uma conta de usuário local.

Acessei o firefox por lá e criei um perfil novo completamente zerado.

Depois acessei o gerenciador de perfil (firefox -P) do firefox e crei um novo perfil copiando todos os dados que tinha na conta administrador para este perfil.

Fiz os testes de impressão e funcionou lá na conta local.

Agora eu fui tentar passar para a conta principal onde logo como administrador e ocorre o mesmo erro na visualização da impressão.

O que vocês me recomendam fazer agora?

Fiquei na dúvida se eu deleto ou desinstalo o firefox por completo e começo tudo novamente ou se existe alguma possibilidade de passar esta conta de usuário local para a conta principal.

Eu já tentei criar um perfil do zero usando o gerenciador de perfis através do comando firefox -p, mas o próprio firefox não me deixa mais criar qualquer perfil novo. Só dá para usar o atual que tenho. Eu não queria apagar este meu perfil atual devido ter personalizado ele por mais de 9 anos. Como já citei acima tem muitos complementos que uso diariamente para o meu trabalho e não posso apagar. Pesquisando na internet através do google eu fiz o seguinte. Criei uma nova conta de usuário no windows sem ser administrador. Uma conta de usuário local. Acessei o firefox por lá e criei um perfil novo completamente zerado. Depois acessei o gerenciador de perfil (firefox -P) do firefox e crei um novo perfil copiando todos os dados que tinha na conta administrador para este perfil. Fiz os testes de impressão e funcionou lá na conta local. Agora eu fui tentar passar para a conta principal onde logo como administrador e ocorre o mesmo erro na visualização da impressão. O que vocês me recomendam fazer agora? Fiquei na dúvida se eu deleto ou desinstalo o firefox por completo e começo tudo novamente ou se existe alguma possibilidade de passar esta conta de usuário local para a conta principal.

Alterado por glalla em

user917725 402 soluções 2382 respostas

Acho que a solução é começar do zero, um perfil de 9 anos é muito tempo e o Firefox está em evolução constante, possivelmente alguma configuração antiga do seu perfil deve estar em conflito com alguma tecnologia mais recente do Firefox.

Acho que a solução é começar do zero, um perfil de 9 anos é muito tempo e o Firefox está em evolução constante, possivelmente alguma configuração antiga do seu perfil deve estar em conflito com alguma tecnologia mais recente do Firefox.

Autor da pergunta

Se eu começar um perfil do zero como que eu faço para salvar todas os complementos citados neste tópico além de todas as configurações que alterei por conta própria e também os favoritos, as senhas e tudo o que eu tenho até o dia de hoje.

Tem algum software ou talvez alguma extensão que salve todos estes dados talvez numa pasta a parte e depois que possa restaurar estas informações sem comprometer o novo perfil a ser criado no firefox?

Se eu começar um perfil do zero como que eu faço para salvar todas os complementos citados neste tópico além de todas as configurações que alterei por conta própria e também os favoritos, as senhas e tudo o que eu tenho até o dia de hoje. Tem algum software ou talvez alguma extensão que salve todos estes dados talvez numa pasta a parte e depois que possa restaurar estas informações sem comprometer o novo perfil a ser criado no firefox?
Zilmar
  • Moderator
94 soluções 738 respostas

O Sync faz isso. Vou citar meu caso, tenho diversas extensões, favoritos e senhas salvas. Quando utilizo um computador novo ou então preciso reinstalar meu sistema operacional, basta logar com o Sync (função nativa do Firefox, inclusive) e ele automaticamente reinstala os complementos, favoritos e demais opções.

Dê uma conferida nesses links: https://www.mozilla.org/pt-BR/firefox/sync/ https://support.mozilla.org/pt-BR/kb/como-faco-para-configurar-sync-meu-computador

O Sync faz isso. Vou citar meu caso, tenho diversas extensões, favoritos e senhas salvas. Quando utilizo um computador novo ou então preciso reinstalar meu sistema operacional, basta logar com o Sync (função nativa do Firefox, inclusive) e ele automaticamente reinstala os complementos, favoritos e demais opções. Dê uma conferida nesses links: https://www.mozilla.org/pt-BR/firefox/sync/ https://support.mozilla.org/pt-BR/kb/como-faco-para-configurar-sync-meu-computador

Autor da pergunta

Olá Zilmar,

Já havia tentado a opção de usar o firefox sync.

Mas, infelizmente ele não salvou quase nada que havia configurado.

Os complementos, preferências e as abas não foram salvos mesmo eu deixando ticado todas as opções citadas.

Infelizmente, esta opção também não deu certo.

Já que neste perfil não tem mesmo como usar a visualização de impressão eu optei em instalar o Pale Moon que é a versão 27 do firefox em inglês.

Claro que não é possível salvar todos os complementos que estão ativos no Firefox 50, mas pelo menos eu consegui usar a visualização de impressão normalmente.

Não era o que eu pretendia fazer, mas pelo menos resolve o meu problema para imprimir qualquer tipo de arquivo, boleto ou página da web.

Olá Zilmar, Já havia tentado a opção de usar o firefox sync. Mas, infelizmente ele não salvou quase nada que havia configurado. Os complementos, preferências e as abas não foram salvos mesmo eu deixando ticado todas as opções citadas. Infelizmente, esta opção também não deu certo. Já que neste perfil não tem mesmo como usar a visualização de impressão eu optei em instalar o Pale Moon que é a versão 27 do firefox em inglês. Claro que não é possível salvar todos os complementos que estão ativos no Firefox 50, mas pelo menos eu consegui usar a visualização de impressão normalmente. Não era o que eu pretendia fazer, mas pelo menos resolve o meu problema para imprimir qualquer tipo de arquivo, boleto ou página da web.
Zilmar
  • Moderator
94 soluções 738 respostas

Olá!

Você já rodou algum software anti-malware? Tente executar o AdwCleaner para remover possíveis malwares e arquivos maliciosos: https://toolslib.net/downloads/finish/1/

Além disso, você possui alguma impressora instalada além da impressora virtual de PDF?

Olá! Você já rodou algum software anti-malware? Tente executar o AdwCleaner para remover possíveis malwares e arquivos maliciosos: https://toolslib.net/downloads/finish/1/ Além disso, você possui alguma impressora instalada além da impressora virtual de PDF?

Autor da pergunta

Oi Zilmar,

Antes de postar aqui eu já havia feito inúmeras verificações com várias ferramentas inclusive com o AdwCleaner.

A impressora virtual de PDF eu desinstalei que é Cute PDF.

Tenho instalado apenas a impressora HP Deskjet 2050.

Oi Zilmar, Antes de postar aqui eu já havia feito inúmeras verificações com várias ferramentas inclusive com o AdwCleaner. A impressora virtual de PDF eu desinstalei que é Cute PDF. Tenho instalado apenas a impressora HP Deskjet 2050.
Zilmar
  • Moderator
94 soluções 738 respostas

Solução escolhida

Olá!

Você poderia testar a funcionalidade iniciando o Windows em modo de segurança?

Outro teste interessante seria desinstalar sua impressora e ver se o problema persiste.

Eu utilizo aqui o Cute Writer, que é da Cute PDF e não tenho problemas.

Olá! Você poderia testar a funcionalidade iniciando o Windows em modo de segurança? Outro teste interessante seria desinstalar sua impressora e ver se o problema persiste. Eu utilizo aqui o [http://www.cutepdf.com/download/CuteWriter.exe Cute Writer], que é da Cute PDF e não tenho problemas.

Autor da pergunta

Olá,

A todos que me ajudaram neste problema com o Firefox consegui finalmente resolver o problema com o visualizar a impressão.

Eu criei numa máquina virtual com o Windows 8.1 um perfil completamente zerado instalando tudo novamente e configurando passo a passo todas os complementos, favoritos, preferências, etc.

Voltei na máquina física também com o Windows 8.1 e entrei dentro da pasta do perfil. Logicamente fiz um backup antes se houvesse qualquer problema. Nesta pasta eu apaguei tudo e depois recortei todo o conteúdo da pasta de perfil criada na máquina virtual.

Finalmente estava tudo funcionando perfeitamente inclusive já testei o visualizador de impressão dentro do firefox e agora abre tudo como era antes.

Obrigado a todos!

Olá, A todos que me ajudaram neste problema com o Firefox consegui finalmente resolver o problema com o visualizar a impressão. Eu criei numa máquina virtual com o Windows 8.1 um perfil completamente zerado instalando tudo novamente e configurando passo a passo todas os complementos, favoritos, preferências, etc. Voltei na máquina física também com o Windows 8.1 e entrei dentro da pasta do perfil. Logicamente fiz um backup antes se houvesse qualquer problema. Nesta pasta eu apaguei tudo e depois recortei todo o conteúdo da pasta de perfil criada na máquina virtual. Finalmente estava tudo funcionando perfeitamente inclusive já testei o visualizador de impressão dentro do firefox e agora abre tudo como era antes. Obrigado a todos!