Pesquisar no site de suporte

Evite golpes de suporte. Nunca pedimos que você ligue ou envie uma mensagem de texto para um número de telefone, ou compartilhe informações pessoais. Denuncie atividades suspeitas usando a opção “Denunciar abuso”.

Learn More

Firefox add-on does not work after packaging into .xpi

  • 1 resposta
  • 1 tem este problema
  • 10 visualizações
  • Última resposta de the-edmeister

more options

I created a very simple firefox addon which replaces plain-text URLs on a page to clickable links. I used 'cfx' command-line utility to create it on my linux machine (Linux Mint latest with cinnamon desktop). When I test the extension using 'cfx test' and 'cfx run', I see the extension works. But when I run 'cfx xpi' to package it into an xpi file for installing, the extension does not convert text urls to links (although it is successfully installed). Strange thing is, the extension works as expected on a Windows machine.

I tried packaging the sdk into the xpi too. Still it does not work. What could be the issue? How do I fix this?

I created a very simple firefox addon which replaces plain-text URLs on a page to clickable links. I used 'cfx' command-line utility to create it on my linux machine (Linux Mint latest with cinnamon desktop). When I test the extension using 'cfx test' and 'cfx run', I see the extension works. But when I run 'cfx xpi' to package it into an xpi file for installing, the extension does not convert text urls to links (although it is successfully installed). Strange thing is, the extension works as expected on a Windows machine. I tried packaging the sdk into the xpi too. Still it does not work. What could be the issue? How do I fix this?

Alterado por rajesh1158 em

Todas as respostas (1)

more options

You might get some help with that in the Add-ons support fora. https://forums.addons.mozilla.org/