Solucionar problemas com plugins como Flash ou Java para corrigir problemas comuns do Firefox

(Redirecionado de Resolvendo problemas de plugins)

Se você estiver tendo problemas com páginas que usam plugins (como o Flash, Java e outros) para exibir determinado conteúdo, você pode precisar verificar se um plug-in está causando o problema.

Os problemas mais comuns causados por plugins incluem:


Este artigo descreve como solucionar problemas com plugins. Se você está tendo um problema com uma extensão ou tema, consulte Solução de problemas com extensões e temas. Para obter informações gerais sobre plugins, consulte Usando plugins no Firefox.

Determinando se um plugin é o problema

Você pode seletivamente desativar plugins, enquanto o Firefox é executado. Se você suspeitar de um determinado plug-in, desative-o primeiro, em seguida teste, para verificar se o problema continua. Se você não souber qual plug-in desabilitar:

  1. Na parte superior da janela, clique no botão FirefoxNa barra de menu do Firefox, clique em FerramentasNa parte superior da janela, clique em Ferramentas, e depois em Complementos para abrir a aba do gerenciador de complementos. Clique no botão de menu New Fx Menu e selecione Complementos para abrir a aba do gerenciador de complementos.

  2. No gerenciador de complementos, selecione o painel Plugins.
  3. Selecione um plugin da lista e clique no botão Desativar. Repita este passo para cada plugin na lista, até que todos eles sejam desativados. Você não precisará reiniciar o Firefox para que as alterações tenham efeito.
  4. Teste o problema que ocorria. Caso não ocorra, volte para a janela de Complementos e reative os plugins um por um com o botão Ativar até encontrar o que causou o problema.
  1. Na parte superior da janela, clique no botão FirefoxNa barra de menu do Firefox, clique em FerramentasNa parte superior da janela, clique em Ferramentas, e depois em Complementos para abrir a aba do gerenciador de complementos. Clique no botão de menu New Fx Menu e selecione Complementos para abrir a aba do gerenciador de complementos.

  2. No gerenciador de complementos, selecione o painel Plugins.
  3. Selecione um plugin da lista e no menu drop-down selecione Nunca Ativar. Repita este passo para cada plugin na lista, até que todos eles sejam desativados. Você não precisará reiniciar o Firefox para que as alterações tenham efeito.
  4. Teste o problema que ocorria. Caso não ocorra, volte para a janela de Complementos e reative os plugins um por um usando o menu drop-down sempre Ativar até encontrar o que causou o problema.

Se você achar que desativar um plugin corrige o problema, continue seguindo os passos descritos neste artigo.

Atualizando e reinstalando seus plugins

Muitos problemas com plugins podem ser resolvidos através da atualização para a versão mais recente do plugin. Para verificar se algum dos seus plugins está desatualizado, visite a página de verificação de plugins.

Se a atualização para a versão mais recente do plugin ou após reinstalá-lo não resolver o problema, você pode deixá-lo desabilitado.

Desinstalando manualmente um plugin

Se você não pode usar um programa desinstalador para remover um plugin, você pode removê-lo manualmente:

  1. No Campo de endereços, digite about:config e pressione EnterReturn.

    • O aviso "As modificações destas configurações avançadas pode prejudicar a estabilidade, a segurança e o desempenho deste aplicativo"' da página about:config poderá aparecer. Clique em Serei cuidadoso, eu prometo! para continuar.
  2. Procure a preferência: plugin.expose_full_path.
  3. Clique duas vezes sobre a preferência plugin.expose_full_path na lista para alterar o valor verdadeiro.
  4. Digite about:plugins na barra de localização e pressione EnterReturn para exibir a página sobre plug-ins.
  5. Cada entrada sobre a página de plug-ins "File name:" followed by a path. Use o Windows Explorer para navegarNavegar para a pasta mostrada para o plugin que você deseja remover.
  6. Renomeie o arquivo para algo diferente de seu nome normal - ex. npswf32 para Xnpswf32
  7. Duplo clique sobre a preferência plugin.expose_full_path na lista da página about:config para alterar o valor de volta para falso to avoid exposing the plugin path to websites.

O plugin será removido.

Se você não pode usar um programa desinstalador para remover um plugin, você pode removê-lo manualmente:

  1. No Campo de endereços, digite about:config e pressione EnterReturn.

    • O aviso "As modificações destas configurações avançadas pode prejudicar a estabilidade, a segurança e o desempenho deste aplicativo"' da página about:config poderá aparecer. Clique em Serei cuidadoso, eu prometo! para continuar.
  2. Procure a preferência: plugin.expose_full_path.
  3. Clique duas vezes sobre a preferência plugin.expose_full_path na lista para alterar o valor verdadeiro.
  4. Digite about:plugins na barra de localização e pressione EnterReturn para exibir a página sobre plug-ins.
  5. Cada entrada sobre a página de plug-ins "File name:" followed by a path. Use o Windows Explorer para navegarNavegar para a pasta mostrada para o plugin que você deseja remover.
  6. Renomeie o arquivo para algo diferente de seu nome normal - ex. npswf32 para Xnpswf32

O plugin será removido.

Re-inicializar o banco de dados de plugins

Em alguns casos, pode não ser capaz de instalar ou re-instalar um plugin. Re-inicializar o banco de dados de plugins pode corrigir esse problema:

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no butão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba Dados para suporte será aberta.Clique no botão New Fx Menu , clique em ajuda Help-29 and select Dados para suporte. A aba Dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se você não conseguir abrir ou usar o Firefox, siga as instruções para Encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Delete o arquivo pluginreg.dat.
  6. Abra o Firefox
  7. Na barra de localização digite about:plugins e pressione EnterReturn para mostrar a lista de plugins do Firefox.



Compartilhe este artigo: http://mzl.la/NYtGci

Este artigo foi útil? Por favor, aguarde...

Colaboradores que ajudaram a escrever este artigo: paulotashiro, Seta00, Apocalypse, ouesten. Você também pode ajudar - descubra como.