Extensões inseguras ou instáveis na lista de bloqueios (blocklist) | Resolução de problemas

Extensões inseguras ou instáveis na lista de bloqueios (blocklist)

Extensões (extensões, temas e plugins) que violam as Diretrizes de Extensão da Mozilla são inseridos na lista de "bloqueios".

O que a lista de bloqueios faz?

Desabilita extensões inseguras

O Firefox bloqueará uma extensão insegura durante o carregamento e lhe apresentará a seguinte mensagem:

O Firefox detectou que as seguintes extensões são conhecidas por causar instabilidade ou falhas de segurança.


Add-ons Blocklist Mac1

Para impedir que essas extensões sejam executadas, clique em Reiniciar Firefox.

Impede que extensões inseguras sejam instaladas

Quando você tentar instalar uma extensão insegura que está na lista de bloqueios, o Firefox bloqueará a instalação e mostrará a mensagem:

A extensão nome não poderá ser instalada porque oferece um grande risco de causar instabilidade ou problemas de segurança.

Evita que plugins rodem automaticamente

O Firefox pode evitar que um plugin rode automaticamente (o que previne muitos problemas). Quando o Firefox bloquear um plugin você verá uma mensagem parecida com essa:

Click to play 1 new

Você pode, em seguida, optar por executar o plugin ou atualizá-lo (caso uma atualização esteja disponível). Para saber mais, veja Por que eu tenho que clicar para ativar plugins?

O suporte a todos os plugins NPAPI - exceto o Flash - foi encerrado quando a versão 52 do Firefox foi lançada. Veja o documento de compatibilidade (em inglês) e esse artigo para maiores detalhes.

A partir da versão 52 do Firefox, o suporte a todos os plugins NPAPI - exceto o Flash - foi encerrado. Veja o documento de compatibilidade (em inglês) e esse artigo para maiores detalhes.

Passo-a-passo

Se a extensão instalada está desabilitada

Extensão ou tema

  1. Clique no menu Fx57menu Extensões Fx57Addons-icon Extensões e selecione Extensões. Será aberta a aba Gerenciador de extensões.

  2. No gerenciador de extensões, selecione o painel Extensões.
  3. No menu "Ferramentas para Extensões" Add-on Tools Icon , certifique-se que o item no menu Atualizar automaticamente está marcado.

Plugin

Verifique se há uma versão atualizada do seu plugin. Se não houver atualizações de plugins disponíveis, talvez seja necessário entrar em contato com o desenvolvedor do plugin que foi bloqueado.

Instalação bloqueada

Se você estiver impedido de instalar uma extensão, confira se existe uma versão atualizada da extensão que está tentando instalar.

Nota: Caso não haja uma versão atualizada para instalação, é necessário entrar em contato com o desenvolvedor da extensão que foi bloqueada.

Quais extensões inseguras estão na lista de bloqueios?

Veja a lista de extensões bloqueadas.

Este artigo foi útil?

Por favor, aguarde...

Contribuidores que ajudaram a escrever esse artigo: Ralph Daub, Ale Galliard, Marco Aurélio, André Marinho, Wolfgang Marcos, Cynthia Pereira, Thiago Policena, Jhonatas Rodrigues . Você também pode ajudar - descubra como.

Última atualização: 2017-07-25

Obter suporte para outra plataforma:
Personalizar esse artigo

Firefox