Corrija a mensagem de erro "Os favoritos e históricos não serão funcionais" | Resolução de problemas

Corrija a mensagem de erro "Os favoritos e históricos não serão funcionais"

Este artigo acima aplica no Firefox 3.5 e superior. Se você tiver problemas com seu favoritos no Firefox 3.0.x, veja Bookmarks and toolbar buttons not working after upgrading para uma solução.

Se você ver esta mensagem de erro ao iniciar o Firefox?

Histórico e favoritos não serão funcionais porque um dos arquivos do Firefox está sendo usado por outro aplicativo, talvez um programa de segurança.

Isso acontece quando o arquivo (chamado places.sqlite) que armazena os seus favoritos e históricos não podem ser acessados no Firefox. Este artigo sugere duas possíveis soluções.

Se você não observou a mensagem acima, então você pode tentar buscar a solução em um dos artigos abaixo:

Solução 1: Reiniciar seu computador

A causa mais comum deste tipo de mensagem é quando um outro programa está utilizando o arquivo (places.sqlite) ou um problema com o arquivo que foi causado porque o computador foi desligado inesperadamente, como por exemplo uma queda de energia. Na maioria dos casos, simplesmente reiniciando-se o computador e iniciando novamente o Firefox pode resolver o problema.

Solução 2: Criar um arquivo de dados

Caso a solução 1 não funcionar, você pode conseguir resolver o problema utilizando o Firefox para criar um novo arquivo de dados ( places database ). Basta seguir os passos abaixo:

Parte 1 – Abrir a pasta do perfil de seu usuário

No topo da janela do Firefox, clique no butão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba Dados para suporte será aberta.Clique no botão New Fx Menu , clique em ajuda Help-29 and select Dados para suporte. A aba Dados para suporte será aberta.

  • Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  • Nota: Se você não conseguir abrir ou usar o Firefox, siga as instruções para Encontrar o seu perfil sem abrir o Firefox.
    Deixar esta pasta aberta e continuar a Parte 2.

    Parte 2 – Criar um novo banco de dados

    1. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

      Clique no botão de menu New Fx Menu e clique em SairSair Close 29

      Esperar até que o Firefox finalize a execução completa.
    2. Na pasta aberta anteriormente, identifique os arquivos "places.sqlite" e places.sqlite-journal' ( caso este último existir ). Após identificar, você deverá renomear estes arquivos.
      • Para renomear arquivos, utilize o botão da direita do mouse e selecione a opção renomear no menu. clicar uma vez em cima do nome do arquivo, selecionando-o, e uma segunda vez para que o texto possa ser alterado. . Em seguida adicione o texto ".old" no final do texto do nome do arquivo.
    1. Reiniciar o Firefox.
      • Quando o Firefox reiniciar, ele deverá criar um novo banco de dados do places. Seu histórico de navegação será perdido mas o Firefox irá automaticamente importar seu histórico a partir do arquivo de backup mais recente.
      • Se o seu arquivo de favoritos não apareceu depois de seguir estes passos, veja a solução Recuperar Favoritos perdidos ou ausentes.

    Ajude-me! O problema não foi resolvido ao fazer os passos acima

    Abaixo estão alguns artigos que podem ser relacionados com problemas com Favoritos e Histórico de Navegação.



    Compartilhe este artigo: http://mzl.la/LLcerE

    Este artigo foi útil?

    Por favor, aguarde...

    Colaboradores que ajudaram a escrever este artigo: mgalli, rjbd. Você também pode ajudar - descubra como.
    Obter suporte para outra plataforma:
    Personalizar esse artigo

    Firefox