Corrigir a mensagem de erro "Não foi possível inicializar o componente de segurança do aplicativo"

Este artigo lida com as causas da mensagem "Não foi possível inicializar o componente de segurança do aplicativo." A causa mais provável são problemas com arquivos da pasta do perfil do aplicativo. Por favor, certifique-se de que o seu usuário do computador não possui restrições de leitura ou escrita e que o HD tem espaço livre. É recomendado que você saia do aplicativo e tente corrigir o problema. Se você continuar a usar esta sessão, você pode ver um comportamento incorreto da aplicação ao acessar recursos de segurança.

Para informações sobre outras mensagens recebidas ao tentar carregar sites, veja Erro ao carregar páginas da web.

Note: Com o recurso Restaurar o Firefox você pode corrigir muitos problemas voltando o Firefox para seu estado padrão sem perder suas informações essenciais. Tente fazer isto antes de partir para algo mais trabalhoso.

Espaço no HD

Verifique o espaço livre do seu disco rígido.

  1. A partir do menu Iniciar do Windows, clique em "Computador" ou "Meu Computador".
  2. Clique com o botão direito do mouse em Local Disk (C:)
  3. Escolha Propriedades. Uma caixa de diálogo vai aparecer.
  4. Vá para a aba Geral.
  1. Vá para o seu Desktop.
    • Pressione F11
  1. Escolha Macintosh HD.
  2. Pressione command+I para exibir a janela de informações Macintosh HD.
  1. Clique no menu Lugares, e selecione Computador.
  2. Clique com o botão direito em Filesystem.
  3. Escolha Propriedades.

Uma caixa de diálogo vai aparecer.

  1. Vá para a aba Básico.

Se ele relata menos de 1MB de espaço livre disponível, você precisa dar mais espaço.

Permissões de arquivos

Verifique as permissões de arquivos em sua pasta de perfil do Firefox. O arquivo chamado cert8.db deve ter permissões de leitura e escrita.

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no butão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba Dados para suporte será aberta.Clique no botão New Fx Menu , clique em ajuda Help-29 and select Dados para suporte. A aba Dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se você não conseguir abrir ou usar o Firefox, siga as instruções para Encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Clique com o botão direito do mouse sobre o arquivo chamado cert8.db.
  6. Escolha Propriedades. Uma caixa de diálogo vai aparecer.
  7. Vá para a aba Geral.
  8. A opção "somente leitura" deve estar desmarcada.
  9. Pressione OK.
  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no butão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba Dados para suporte será aberta.Clique no botão New Fx Menu , clique em ajuda Help-29 and select Dados para suporte. A aba Dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se você não conseguir abrir ou usar o Firefox, siga as instruções para Encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Selecione o arquivo chamado cert8.db.
  6. Pressione command+I para exibir a janela de informações cert8.db .
  7. Expanda a seção Permissões & Compartilhar.
  8. Certifique-se que sua conta de usuário Mac está definido para Leitura & Gravação.
  9. Feche a janela de informações cert8.db.
  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no butão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba Dados para suporte será aberta.Clique no botão New Fx Menu , clique em ajuda Help-29 and select Dados para suporte. A aba Dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se você não conseguir abrir ou usar o Firefox, siga as instruções para Encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Clique com o botão direito do mouse sobre o arquivo chamado cert8.db.
  6. Escolha Propriedades. Uma caixa de diálogo vai aparecer.
  7. Vá para o Permissões aba.
  8. Certifique que está definido para leitura e escrita leitura e gravação.
  9. Pressione Fechas.

Reinicie o Firefox para o problema ser resolvido.

Arquivo corrompido

O arquivo cert8.db na sua pasta de perfil pode ter sido corrompido. Exclua esse arquivo quando o Firefox estiver fechado.

  1. Abra a pasta do seu perfil:

    No topo da janela do Firefox, clique no butão Firefox, vá até o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Dados para suporte. A aba Dados para suporte será aberta.Clique no botão New Fx Menu , clique em ajuda Help-29 and select Dados para suporte. A aba Dados para suporte será aberta.

  2. Abaixo da seção Informações básicas sobre o aplicativo, clique em Abrir Pastaabrir no FinderAbrir pasta. Uma janela com o seu perfil será aberta.
  3. Nota: Se você não conseguir abrir ou usar o Firefox, siga as instruções para Encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  5. Clique no arquivo chamado cert8.db.
  6. Pressione command+Delete.
  7. Reinicie o Firefox.
cert8.db será recriado quando você reiniciar o Firefox. Isso é normal.

Novo perfil

Suas configurações podem ter sido corrompidas devido a mudanças no seu sistema ou falta de espaço no disco rígido em algum momento. Crie um novo perfil com o Profile Manager. Se o problema desaparecer, então você pode mover suas configurações para o novo perfil. Se o problema persistir, você poderá voltar ao seu perfil original.




Com base nas informações Could not initialize the applications security component (mozillaZine KB)



Compartilhe este artigo: http://mzl.la/N6hG6N

Este artigo foi útil? Por favor, aguarde...

Colaboradores que ajudaram a escrever este artigo: rodrigocft, rjbd. Você também pode ajudar - descubra como.