Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

How to save a web page as a file with extention ".html" instead ".htm"?

  • 9 odpowiedzi
  • 2 osoby mają ten problem
  • 152 wyświetlenia
  • Ostatnia odpowiedź od the-edmeister

more options

Firefox 28. Menu File-Save As-Web page, HTML Only (*.htm,*html) saves to a file with the extention ".htm". How to save a web page as a file with the extention ".html" instead ".htm"?

Wszystkie odpowiedzi (9)

more options

This is an extra step needed, but what I do is

  • File > Save As > Web Page, complete > and manually type out ".html"
more options

Another web page will need same manual change of extention. How to make Firefox automaticaly set file extention (for saving web page) to ".html"

more options

Why can't you just leave the htm file extension there?

more options

Then, why does exist (*.html) in menu?

more options

Firefox doesn't add or modify the file extension automatically, so you will have to add a missing file extension or correct a wrong file extension yourself if the wrong file extension is shown.

You can try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

There is not "HTM" in the mimeTypes.rdf file. From where FireFox get "HTM" for "text/html" mime type? So that I can change it? To Firefox saves a web page as "web-page-title.html"?

more options

I took a look in the "nsFilePicker.cpp". Is therr some comments on "// This is supposed to append ".htm"?

 NS_NAMED_LITERAL_STRING(htmExt, "html");
 if (!mDefaultExtension.IsEmpty()) {
   ofn.lpstrDefExt = mDefaultExtension.get();
 } else if (IsDefaultPathHtml()) {
   // Get file extension from suggested filename to detect if we are
   // saving an html file.
   // This is supposed to append ".htm" if user doesn't supply an
   // extension but the behavior is sort of weird:
   // - Often appends ".html" even if you have an extension
   // - It obeys your extension if you put quotes around name
   ofn.lpstrDefExt = htmExt.get();
 }
more options

in the "save as type" category, select "all files", then type the name of your file followed by the extension .html, e.g "foo.html". This will work.

more options

^ samarnikhil

The Owner of this thread said

"Another web page will need same manual change of extention. How to make Firefox automaticaly set file extention (for saving web page) to ".html" "