Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Is it possible to disable scrolling of tabs with mouse wheel?

  • 5 odpowiedzi
  • 1 osoba ma ten problem
  • 83 wyświetlenia
  • Ostatnia odpowiedź od Dmitry Zorin

more options

Often I close tabs using middle mouse button which is also the wheel. When I point cursor on the tabs, wheel accidently rotates and I close wrong page tab.

Often I close tabs using middle mouse button which is also the wheel. When I point cursor on the tabs, wheel accidently rotates and I close wrong page tab.

Wybrane rozwiązanie

I solved my problem by setting "browser.tabs.closeButtons" option parameter to "2" in "about:config" page. Now all tab close buttons is turned off (do not appear).

Przeczytaj tę odpowiedź w całym kontekście 👍 0

Wszystkie odpowiedzi (5)

more options

You can use one close X at the far right end of the Tab bar and use that button if the tabs get small and you have difficulties to close a tab.

more options

Sorry, but I don't have difficulties to close a tab. I have difficulties to close the correct tab.

more options

You can't disable the tab scrolling with the mouse wheel AFAIK, so you need to use other means to close the tab.
You can close the current tab with the close X on the tab or one close X at the end of the tab bar or use the keyboard with Ctrl+W.
Not selected tabs can only be closed via the right-click context menu as an alternative.

Otherwise you can try to set the minimum width of a tab to a larger value to have more room with the scrolling.

more options

Thanks for reply. I tried this addon, but setting "minimum width" of tabs is useless. Wheel scrolling works by formula: TabWidth * 3 (multiplied by 3). So the larger the tab width, the more scrolling I get.

more options

Wybrane rozwiązanie

I solved my problem by setting "browser.tabs.closeButtons" option parameter to "2" in "about:config" page. Now all tab close buttons is turned off (do not appear).