X
Stuknij, by przejść do witryny w wersji zoptymalizowanej dla urządzeń przenośnych.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Forum pomocy

How do I prevent a website like Drudgereport from automatically reloading?

Wysłano

Sometimes my wifi connection is choppy (darn that microwave popcorn!) and I hate it when I'm in the middle of reading the links in Drudge and it reloads....sometimes shifting the layout a bit or just hanging while it waits for some adserver to respond.

Is there any way to stop this from happening? Tried Freezing the tab. And for some reason, firefox is not preventing this page from automatically reloading like it does others.

Any ideas?

Sometimes my wifi connection is choppy (darn that microwave popcorn!) and I hate it when I'm in the middle of reading the links in Drudge and it reloads....sometimes shifting the layout a bit or just hanging while it waits for some adserver to respond. Is there any way to stop this from happening? Tried Freezing the tab. And for some reason, firefox is not preventing this page from automatically reloading like it does others. Any ideas?

Wybrane rozwiązanie

That site relies upon JavaScript to reload the page. There are a couple of add-ons that can be used to block JavaScipt.

The first is NoScript, this extension will by default block JavaScript on all sites, you then specify what sites that you want to run JavaScript. https://addons.mozilla.org/firefox/addon/noscript

The second is YesScript, this one takes the opposite approach, it allows JavaScript to run on any site, you then specify what sites you want to block JavaScript on. https://addons.mozilla.org/firefox/addon/yesscript

Przeczytaj tę odpowiedź w całym kontekście 1

Dodatkowe dane o systemie

Zainstalowane wtyczki

  • Allows browsing on RealArcade sites with Mozilla browsers.
  • npigl
  • np-mswmp
  • 1.2.0.1256
  • DivX Web Player version 1.4.3.4
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Shockwave Flash 10.2 r153
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Aplikacja

  • Identyfikator przeglądarki: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Więcej informacji

had issues with 3.6 and now 4.0.

TonyE
  • Moderator
1044 rozwiązań 8863 odpowiedzi

Wybrane rozwiązanie

That site relies upon JavaScript to reload the page. There are a couple of add-ons that can be used to block JavaScipt.

The first is NoScript, this extension will by default block JavaScript on all sites, you then specify what sites that you want to run JavaScript. https://addons.mozilla.org/firefox/addon/noscript

The second is YesScript, this one takes the opposite approach, it allows JavaScript to run on any site, you then specify what sites you want to block JavaScript on. https://addons.mozilla.org/firefox/addon/yesscript

That site relies upon JavaScript to reload the page. There are a couple of add-ons that can be used to block JavaScipt. The first is NoScript, this extension will by default block JavaScript on all sites, you then specify what sites that you want to run JavaScript. https://addons.mozilla.org/firefox/addon/noscript The second is YesScript, this one takes the opposite approach, it allows JavaScript to run on any site, you then specify what sites you want to block JavaScript on. https://addons.mozilla.org/firefox/addon/yesscript

Zadający pytanie

Thanks TonyE. Installed Yescript and added drudgereport to the list...crossing my fingers, though I really think it'll work. I'll check in a few hours to see if it worked.

    • edit**

Yep...it worked. Loaded Drudge in IE and it was different. Thanks! I used NoScript years ago, and never updated during the many Firefox upgrades. Glad you pointed out YesScript...that seems to suit my needs better.

Thanks again.

Thanks TonyE. Installed Yescript and added drudgereport to the list...crossing my fingers, though I really think it'll work. I'll check in a few hours to see if it worked. **edit** Yep...it worked. Loaded Drudge in IE and it was different. Thanks! I used NoScript years ago, and never updated during the many Firefox upgrades. Glad you pointed out YesScript...that seems to suit my needs better. Thanks again.

Zmodyfikowany przez dydx w dniu

cor-el
  • Top 10 Contributor
  • Moderator
17856 rozwiązań 161585 odpowiedzi

Pomocna odpowiedź

You can also use a simple JavaScript bookmarklet to stop the refresh timer. You need to repeat that with every reload unless you change the code to a Greasemonkey script that runs on that site.

javascript:clearInterval(timer);void(autoRefresh=null);

<!-- 
var timer = setInterval("autoRefresh()", 1000 * 60 * 3);
function autoRefresh(){self.location.reload(true);}
//-->

http://userscripts.org/scripts/show/13594 - Prevent automatic reload for drudgereport.com (doesn't seem to work properly)

You can also use a simple JavaScript bookmarklet to stop the refresh timer. You need to repeat that with every reload unless you change the code to a Greasemonkey script that runs on that site. <pre><nowiki>javascript:clearInterval(timer);void(autoRefresh=null); </nowiki></pre> * http://en.wikipedia.org/wiki/Bookmarklet ---- <pre><nowiki><!-- var timer = setInterval("autoRefresh()", 1000 * 60 * 3); function autoRefresh(){self.location.reload(true);} //--> </nowiki></pre> http://userscripts.org/scripts/show/13594 - Prevent automatic reload for drudgereport.com (doesn't seem to work properly)

Zadający pytanie

This seems like it has some good uses too. Thanks for this tip.

This seems like it has some good uses too. Thanks for this tip.
reefer 0 rozwiązań 3 odpowiedzi

It seems like too often people have these great answers...but DON'T follow through. I found the way to completely stop DRUDGEREPORT from refreshing at all is to install the YesScript...then go to OPTIONS and add: "www.drudgereport.com" (without the quotation marks of course) and then X out. NOW...go back to your desktop. Completely out of Drudge now. NOW..start drudgereport up. That should do it. Wait a couple minutes and see.

It seems like too often people have these great answers...but DON'T follow through. I found the way to completely stop DRUDGEREPORT from refreshing at all is to install the YesScript...then go to OPTIONS and add: "www.drudgereport.com" (without the quotation marks of course) and then X out. NOW...go back to your desktop. Completely out of Drudge now. NOW..start drudgereport up. That should do it. Wait a couple minutes and see.