Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Keep receiving "Secure Connection Failed" error (attempted fixes have not helped)

  • 3 odpowiedzi
  • 2 osoby mają ten problem
  • 31 wyświetleń
  • Ostatnia odpowiedź od cor-el

more options

When opening various webpages or within embedded media, I frequently keep getting an error message saying: "Secure Connection Failed" generally followed with the error code "PR_END_OF_FILE_ERROR" (usually this code, however I've seen several others). While I can hit refresh or the "try again" option and it will almost always work at loading the webpage, it's incredibly annoying and obtrusive to have to do this with practically every website I visit.

I first started noticing this issue a day or so ago after switching on the HTTPS-Only mode setting in Privacy & Security. I've tried using all the various configurations of this setting (on, off, only in private) but to no avail. I've tried with my VPN on and off, I've restarted my device, and I've cleared my cookies and cached data. None of these have helped me. I'd very much like to find a fix for this so I can get back to work as normal. Thank you for any help you can provide

I'm currently using Firefox version 92 (64bit) on a Windows 10, if that information is needed.

Wszystkie odpowiedzi (3)

more options

Please, I need help. This is very annoying. If I can't find a solution, I am going to have to make Chrome my default browser.

Pomocne?

more options

Maria Luisa Castellanos said

Please, I need help.

Hi Maria, are you also getting an error page showing the code PR_END_OF_FILE_ERROR?

Next Steps

(1) Turn off any proxy

You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

Try setting this to "No proxy" at the top, and saving the change using the button at the bottom.

Any difference?

(2) Clear Cache and Site Cookies

When you have a new problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (just "Cached Web Content")

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

(3) Investigate A Possible "Man in the middle"

This will be covered in a future post if needed.

Pomocne?

more options

You appear to have a user agent that is modified by Avast/AVG Anti-Track that could be causing problems, so if you do use this software then try to disable it. You will have to contact Avast about this if their software causes problems for you.

Pomocne?

Zadaj pytanie

Aby odpowiadać na posty, musisz zalogować się na swoje konto. Zadaj pytanie, jeśli nie masz jeszcze konta.