X
Stuknij, by przejść do witryny w wersji zoptymalizowanej dla urządzeń przenośnych.

Forum pomocy

How to prevent uninstall/removal of add one from toolbar?

Wysłano

Hi all,

I would like to know, how I can prevent the uninstall of addons from the toolbar menu? Even if I decide to remove them from the toolbar with customize, I can still uninstall them after moving them back up to the toolbar with customize.

Is there some add on that password locks this from happening?

My reason for doing this is because I have lots of younger relatives who use my laptop sometimes to play games. I want to make sure they are safe on the internet and not messing around with key settings.

Thanks in advance!

Hi all, I would like to know, how I can prevent the uninstall of addons from the toolbar menu? Even if I decide to remove them from the toolbar with customize, I can still uninstall them after moving them back up to the toolbar with customize. Is there some add on that password locks this from happening? My reason for doing this is because I have lots of younger relatives who use my laptop sometimes to play games. I want to make sure they are safe on the internet and not messing around with key settings. Thanks in advance!
Cytuj

Dodatkowe dane o systemie

Aplikacja

  • Identyfikator przeglądarki: Mozilla/5.0 (Android 9; Mobile; rv:67.0) Gecko/67.0 Firefox/67.0

Więcej informacji

cor-el
  • Top 10 Contributor
  • Moderator
17407 rozwiązań 157253 odpowiedzi

You can lock extensions to prevent them from being removed and you can lock access to the about:addons page via a policies.json file.

You can lock extensions to prevent them from being removed and you can lock access to the about:addons page via a policies.json file. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson *https://github.com/mozilla/policy-templates/blob/master/README.md
Czy ta odpowiedź okazała się pomocna?
Cytuj

Zadający pytanie

@cor-el

Hi,

Thanks for reply.

I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work.

Here's what my code looks like:

{

 "policies": {
   "Extensions": {
     "Locked":  ["addon_id@mozilla.org"]
   }
 }

}

Not sure what I'm doing wrong.

@cor-el Hi, Thanks for reply. I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work. Here's what my code looks like: { "policies": { "Extensions": { "Locked": ["addon_id@mozilla.org"] } } } Not sure what I'm doing wrong.
Czy ta odpowiedź okazała się pomocna?
Cytuj
cor-el
  • Top 10 Contributor
  • Moderator
17407 rozwiązań 157253 odpowiedzi

You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock. Easiest to get the ID is to install the extension and look for it on the about:debugging page.

You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock. Easiest to get the ID is to install the extension and look for it on the about:debugging page.
Czy ta odpowiedź okazała się pomocna?
Cytuj
jscher2000
  • Top 10 Contributor
8632 rozwiązań 70597 odpowiedzi

Aman said

I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work.

By the way, if Windows says your policies.json file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily.

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

''Aman [[#answer-1244800|said]]'' <blockquote> I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work. </blockquote> By the way, if Windows says your '''policies.json''' file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily. https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/
Czy ta odpowiedź okazała się pomocna?
Cytuj

Zadający pytanie

cor-el said

You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock. Easiest to get the ID is to install the extension and look for it on the about:debugging page.

Would this be something I'd have to do for each individual add on? Also, would the code still work if I list every extension control parameters in the same bracket?

''cor-el [[#answer-1244808|said]]'' <blockquote> You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock. Easiest to get the ID is to install the extension and look for it on the about:debugging page. </blockquote> Would this be something I'd have to do for each individual add on? Also, would the code still work if I list every extension control parameters in the same bracket?
Czy ta odpowiedź okazała się pomocna?
Cytuj

Zadający pytanie

jscher2000 said

Aman said
I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work.

By the way, if Windows says your policies.json file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily.

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Thanks, but I already had that option enabled. I did add the .txt to the end though.

''jscher2000 [[#answer-1244812|said]]'' <blockquote> ''Aman [[#answer-1244800|said]]'' <blockquote> I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work. </blockquote> By the way, if Windows says your '''policies.json''' file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily. https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/ </blockquote> Thanks, but I already had that option enabled. I did add the .txt to the end though.
Czy ta odpowiedź okazała się pomocna?
Cytuj
jscher2000
  • Top 10 Contributor
8632 rozwiązań 70597 odpowiedzi

Aman said

jscher2000 said
Aman said
I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work.

By the way, if Windows says your policies.json file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily.

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Thanks, but I already had that option enabled. I did add the .txt to the end though.

Sorry, you do not want .txt at the end. You want .json to be the true file extension.

''Aman [[#answer-1244826|said]]'' <blockquote> ''jscher2000 [[#answer-1244812|said]]'' <blockquote> ''Aman [[#answer-1244800|said]]'' <blockquote> I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work. </blockquote> By the way, if Windows says your '''policies.json''' file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily. https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/ </blockquote> Thanks, but I already had that option enabled. I did add the .txt to the end though. </blockquote> Sorry, you do not want .txt at the end. You want .json to be the true file extension.
Czy ta odpowiedź okazała się pomocna?
Cytuj
jscher2000
  • Top 10 Contributor
8632 rozwiązań 70597 odpowiedzi

Aman said

cor-el said
Aman said
Here's what my code looks like:
{
  "policies": {
    "Extensions": {
      "Locked":  ["addon_id@mozilla.org"]
    }
  }
}

Not sure what I'm doing wrong.

You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock.

Easiest to get the ID is to install the extension and look for it on the about:debugging page.

Would this be something I'd have to do for each individual add on? Also, would the code still work if I list every extension control parameters in the same bracket?

The [] holds an array, which is a comma-separated list of quoted items. So for example:

[ "{73a6fe31-595d-460b-a920-fcc0f8843232}", "jid1-93WyvpgvxzGATw@jetpack", "savepage-we@DW-dev" ]

To get the IDs, you also can consult the Extensions section of the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down past "Application Basics" and "Firefox Features" to "Extensions". The friendly name is on the left and the ID is on the right.

''Aman [[#answer-1244822|said]]'' <blockquote> ''cor-el [[#answer-1244808|said]]'' <blockquote> ''Aman [[#answer-1244800|said]]'' <blockquote>Here's what my code looks like: <pre>{ "policies": { "Extensions": { "Locked": ["addon_id@mozilla.org"] } } } </pre> Not sure what I'm doing wrong. </blockquote>You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock. Easiest to get the ID is to install the extension and look for it on the about:debugging page. </blockquote> Would this be something I'd have to do for each individual add on? Also, would the code still work if I list every extension control parameters in the same bracket? </blockquote> The [] holds an array, which is a comma-separated list of quoted items. So for example: [ "{73a6fe31-595d-460b-a920-fcc0f8843232}", "jid1-93WyvpgvxzGATw@jetpack", "savepage-we@DW-dev" ] To get the IDs, you also can consult the Extensions section of the Troubleshooting Information page. Either: * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter Scroll down past "Application Basics" and "Firefox Features" to "Extensions". The friendly name is on the left and the ID is on the right.
Czy ta odpowiedź okazała się pomocna?
Cytuj

Zadający pytanie

jscher2000 said

Aman said
jscher2000 said
Aman said
I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work.

By the way, if Windows says your policies.json file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily.

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Thanks, but I already had that option enabled. I did add the .txt to the end though.

Sorry, you do not want .txt at the end. You want .json to be the true file extension.

Ah ok, will make that change.

''jscher2000 [[#answer-1244834|said]]'' <blockquote> ''Aman [[#answer-1244826|said]]'' <blockquote> ''jscher2000 [[#answer-1244812|said]]'' <blockquote> ''Aman [[#answer-1244800|said]]'' <blockquote> I've got ahead and made a notepad file with the Extension control code in my Firefox Distribution folder, but it didn't seem to work. </blockquote> By the way, if Windows says your '''policies.json''' file is a Notepad or Text file, there could be a hidden .txt extension on the file name. To take firmer control of file naming, you could set Windows to show all file extensions, at least temporarily. https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/ </blockquote> Thanks, but I already had that option enabled. I did add the .txt to the end though. </blockquote> Sorry, you do not want .txt at the end. You want .json to be the true file extension. </blockquote> Ah ok, will make that change.
Czy ta odpowiedź okazała się pomocna?
Cytuj

Zadający pytanie

jscher2000 said

Aman said
cor-el said
Aman said
Here's what my code looks like:
{
  "policies": {
    "Extensions": {
      "Locked":  ["addon_id@mozilla.org"]
    }
  }
}

Not sure what I'm doing wrong.

You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock.

Easiest to get the ID is to install the extension and look for it on the about:debugging page.

Would this be something I'd have to do for each individual add on? Also, would the code still work if I list every extension control parameters in the same bracket?

The [] holds an array, which is a comma-separated list of quoted items. So for example:

[ "{73a6fe31-595d-460b-a920-fcc0f8843232}", "jid1-93WyvpgvxzGATw@jetpack", "savepage-we@DW-dev" ]

To get the IDs, you also can consult the Extensions section of the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down past "Application Basics" and "Firefox Features" to "Extensions". The friendly name is on the left and the ID is on the right.

Here is what I currently have:


{

 "policies": {
   "Extensions": {
     "Locked":  ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}, "]
   }
 }

}

Not sure if it's right.

''jscher2000 [[#answer-1244838|said]]'' <blockquote> ''Aman [[#answer-1244822|said]]'' <blockquote> ''cor-el [[#answer-1244808|said]]'' <blockquote> ''Aman [[#answer-1244800|said]]'' <blockquote>Here's what my code looks like: <pre>{ "policies": { "Extensions": { "Locked": ["addon_id@mozilla.org"] } } } </pre> Not sure what I'm doing wrong. </blockquote>You need to replace "addon_id@mozilla.org" with the actual ID of the extension that you want to lock. Easiest to get the ID is to install the extension and look for it on the about:debugging page. </blockquote> Would this be something I'd have to do for each individual add on? Also, would the code still work if I list every extension control parameters in the same bracket? </blockquote> The [] holds an array, which is a comma-separated list of quoted items. So for example: [ "{73a6fe31-595d-460b-a920-fcc0f8843232}", "jid1-93WyvpgvxzGATw@jetpack", "savepage-we@DW-dev" ] To get the IDs, you also can consult the Extensions section of the Troubleshooting Information page. Either: * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter Scroll down past "Application Basics" and "Firefox Features" to "Extensions". The friendly name is on the left and the ID is on the right. </blockquote> Here is what I currently have: { "policies": { "Extensions": { "Locked": ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}, "] } } } Not sure if it's right.
Czy ta odpowiedź okazała się pomocna?
Cytuj
cor-el
  • Top 10 Contributor
  • Moderator
17407 rozwiązań 157253 odpowiedzi

You only need a comma as separator for multiple items in the array ["<id-1>","<id-2>"] and no trialing comma before the closing bracket.

{
  "policies": {
    "Extensions": {
      "Locked":   ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}"]
    }
  }
}
You only need a comma as separator for multiple items in the array ["<id-1>","<id-2>"] and no trialing comma before the closing bracket. <pre><nowiki>{ "policies": { "Extensions": { "Locked": ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}"] } } }</nowiki></pre>
Czy ta odpowiedź okazała się pomocna?
Cytuj

Zadający pytanie

cor-el said

You only need a comma as separator for multiple items in the array ["<id-1>","<id-2>"] and no trialing comma before the closing bracket.
{
  "policies": {
    "Extensions": {
      "Locked":   ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}"]
    }
  }
}

It doesn't seem to be working for me. If I go to the Firefox Addon page, I can simply click remove and it removes it.

''cor-el [[#answer-1245035|said]]'' <blockquote> You only need a comma as separator for multiple items in the array ["<id-1>","<id-2>"] and no trialing comma before the closing bracket. <pre><nowiki>{ "policies": { "Extensions": { "Locked": ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}"] } } }</nowiki></pre> </blockquote> It doesn't seem to be working for me. If I go to the Firefox Addon page, I can simply click remove and it removes it.
Czy ta odpowiedź okazała się pomocna?
Cytuj
cor-el
  • Top 10 Contributor
  • Moderator
17407 rozwiązań 157253 odpowiedzi

If you mean the extension's page on the AMO (Add-ons) website then this is likely this bug that was recently fixed for Firefox 68.1 ESR (and 69/70).

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

If you mean the extension's page on the AMO (Add-ons) website then this is likely this bug that was recently fixed for Firefox 68.1 ESR (and 69/70). *[https://bugzilla.mozilla.org/show_bug.cgi?id=1568921 Bug 1568921] - Addons.mozilla.org can uninstall add-ons locked with policies (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Czy ta odpowiedź okazała się pomocna?
Cytuj

Zadający pytanie

Aman said

cor-el said
You only need a comma as separator for multiple items in the array ["<id-1>","<id-2>"] and no trialing comma before the closing bracket.
{
  "policies": {
    "Extensions": {
      "Locked":   ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}"]
    }
  }
}

It doesn't seem to be working for me. If I go to the Firefox Addon page, I can simply click remove and it removes it.

Also, to clarify, If I have the locked function in my .json file, It should prevent any ability to "remove extension" if Firefox is up to date?

''Aman [[#answer-1245245|said]]'' <blockquote> ''cor-el [[#answer-1245035|said]]'' <blockquote> You only need a comma as separator for multiple items in the array ["<id-1>","<id-2>"] and no trialing comma before the closing bracket. <pre><nowiki>{ "policies": { "Extensions": { "Locked": ["{dd3d7613-0246-469d-bc65-2a3cc1668adc}"] } } }</nowiki></pre> </blockquote> It doesn't seem to be working for me. If I go to the Firefox Addon page, I can simply click remove and it removes it. </blockquote> Also, to clarify, If I have the locked function in my .json file, It should prevent any ability to "remove extension" if Firefox is up to date?
Czy ta odpowiedź okazała się pomocna?
Cytuj
Zadaj pytanie

Aby odpowiadać na posty, musisz zalogować się na swoje konto. Zadaj pytanie, jeśli nie masz jeszcze konta.