Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

How can I turn off ClearType in Firefox 58?

  • 2 odpowiedzi
  • 1 osoba ma ten problem
  • 6 wyświetleń
  • Ostatnia odpowiedź od Bobram

more options

I have ClearType turned off in my Windows settings. In previous versions of Firefox I was able to get Firefox to stop using ClearType by making these additional settings: Turn off Hardware Acceleration in the Performance options, and put "skia" last in the list in gfx.content.azure.backends.

With Firefox 58, ClearType is being used in more places in spite of these settings. Text in the menu bar, tabs, address bar, and search bar is being rendered in ClearType. So is some content text in some web sites (GMail for example), but I haven't figured out what determines which way a given piece of text will be rendered.

Are there any additional Firefox settings I can use to suppress ClearType?

I have ClearType turned off in my Windows settings. In previous versions of Firefox I was able to get Firefox to stop using ClearType by making these additional settings: Turn off Hardware Acceleration in the Performance options, and put "skia" last in the list in gfx.content.azure.backends. With Firefox 58, ClearType is being used in more places in spite of these settings. Text in the menu bar, tabs, address bar, and search bar is being rendered in ClearType. So is some content text in some web sites (GMail for example), but I haven't figured out what determines which way a given piece of text will be rendered. Are there any additional Firefox settings I can use to suppress ClearType?

Wszystkie odpowiedzi (2)

more options

ClearType is a Windows O/S property.

more options

As I said in my description of the problem: I have ClearType turned off in the Windows settings, but Firefox is not complying with this setting.

As of Firefox version 57, I was able to prevent Firefox from using ClearType by making additional settings in Firefox. Besides the ones I referenced in my problem description, I should add that I also have gfx.direct2d.disabled set to true. As soon as I upgraded to Firefox 58, the text rendering in some components and web pages changed, so that it now appears I have ClearType in several places.

Text rendering is a complex subject, so it's possible that what I am calling ClearType rendering is actually some other kind of blurry rendering. But whatever it is, it looks exactly the way text used to look if I turned ClearType on.

The point is, certain pieces of text that displayed with crisp edges in Firefox 57 now displays with blurry edges in Firefox 58, without having changed any settings either in Windows or in Firefox. Does anyone know of any settings I can change in Firefox that would fix it?