Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Firefox Quantum private browsing disables add-on toolbar controls (NoScript & Disconnect)

  • 5 odpowiedzi
  • 9 osób ma ten problem
  • 19 wyświetleń
  • Ostatnia odpowiedź od bificommander

more options

When I engage private browsing in Firefox Quantum, the toolbar buttons for my two add-ons, NoScript and Disconnect, become non-functional. In regular browsing, clicking these buttons will open a small menu where I can select which sites I want to provide exceptions to, but in private browser NoScript opens nothing and Disconnect opens a tiny empty window. The add-ons still work, scripts are being blocked, but I can't review what's being blocked, or allow anything through.

Is there any way to change this behavior? I know it didn't happen in the previous Firefox version. Is this due to a customizable setting in Firefox?

Wybrane rozwiązanie

bificommander

I recall seeing mention of something like that about NoScript yesterday, but I can find that thread right now in my browsing history.

iirc, it was about NoScript being disabled when in Private Browsing mode and that the NoScript developer still had that on his TO-DO list. It seems that the re-write to WE took longer than expected so not everything on that list made it into the initial release.

As far as Disconnect - never used it and I have no interest in it.

Edit: WHOOPS, forgot to provide a hyperlink to NoScript support fora: https://forums.informaction.com/viewforum.php?f=7&sid=7a8c6098aee607861654ae2973819ac6

Przeczytaj tę odpowiedź w całym kontekście 👍 0

Wszystkie odpowiedzi (5)

more options

I would say not Private Browsing is using privacy features that were in Tor Browser. So is very safe, still bleeds a little info though. Both Private and regular have a Sand Boxed Environment.

So yours go out, and my Ghostery, HTTPS Everywhere, uBlock Origin and Norton Safe Web still work in Private Browsing.

So on that note, I do not have a clue. Someone with more experience will have to have a look.

Though all my stuff works very differently than yours. Answer back so this stays in the to do list.

more options

As you say, I'll answer back. And I'm afraid it's not safe enough in private browsing without NoScript. I tried leaving it off, but that drowned me in extra pop-up windows being opened, including one that insisted to install its own crap and wouldn't close without help from the task manager.

Zmodyfikowany przez bificommander w dniu

more options

You will have to answer 1 more time. If going to sites like that could try using just Tor.

With my adblockers and paid Malwarebytes I never have issues if are can not remember last time, So Malwarebytes blocks from black lists as does my Norton, Firefox blocks with Google. So I usually saved by one of them.

Here is something a program called Peerblock, download your block lists from Iblock, my have to edit your ISP out of the list as friend got heck for blocking ISP, not sure who why unless shared numbers. Anyways Covers a lot of web addresses. Something to think about.

more options

Wybrane rozwiązanie

bificommander

I recall seeing mention of something like that about NoScript yesterday, but I can find that thread right now in my browsing history.

iirc, it was about NoScript being disabled when in Private Browsing mode and that the NoScript developer still had that on his TO-DO list. It seems that the re-write to WE took longer than expected so not everything on that list made it into the initial release.

As far as Disconnect - never used it and I have no interest in it.

Edit: WHOOPS, forgot to provide a hyperlink to NoScript support fora: https://forums.informaction.com/viewforum.php?f=7&sid=7a8c6098aee607861654ae2973819ac6

Zmodyfikowany przez the-edmeister w dniu

more options

It appears that an update for NoScript just came out that fixed the problem. Since I had exactly two add-on toolbar buttons and neither worked I thought it might be a Firefox setting, but it appears to have been bugs in the add-ons. Thank you for your time.