Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Why does Firefox insist on using https when the server port is other than 80?

  • 1 odpowiedź
  • 1 osoba ma ten problem
  • 3 wyświetlenia
  • Ostatnia odpowiedź od Poltsi

more options

Firefox 56.0 Linux.

I do web-related docker development on an internal network and have not bothered to reroute the container ports to 80. The services in the docker containers are configured to answer in http-only.

Everytime I attempt to connect with Firefox to any of these services, eg. http://docker.my.private.network:8888 the browser immediately changes to https://docker.my.private.network:8888 and as a result gives an error since the response is not https, but plain http, like so:

Secure Connection Failed

An error occurred during a connection to docker.my.private.network:8888. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

I'm pretty sure the advice given above is misleading as this only happens with Firefox. If I use eg. Chrome with exactly the same address string I only get an complaint (as it should) that the connection is not secured. I get the same behavior when I run Firefox with all the plugins/add-ons disabled.

Firefox 56.0 Linux. I do web-related docker development on an internal network and have not bothered to reroute the container ports to 80. The services in the docker containers are configured to answer in http-only. Everytime I attempt to connect with Firefox to any of these services, eg. http://docker.my.private.network:8888 the browser immediately changes to https://docker.my.private.network:8888 and as a result gives an error since the response is not https, but plain http, like so: Secure Connection Failed An error occurred during a connection to docker.my.private.network:8888. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. I'm pretty sure the advice given above is misleading as this only happens with Firefox. If I use eg. Chrome with exactly the same address string I only get an complaint (as it should) that the connection is not secured. I get the same behavior when I run Firefox with all the plugins/add-ons disabled.

Wszystkie odpowiedzi (1)

more options

To add a twist to this plot:

If I use SSH portforwarding in the following manner: ssh user@docker -L 8888:localhost:8888 And then connect with Firefox to the address http://localhost:8888 I get no error, and the browser does not switch to https.

It is quite obvious that the problem lies within Firefox which seems to have a broken logic when it tries to decide whether a site defacto uses SSL or not.

Zmodyfikowany przez Poltsi w dniu