On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Why is FF blocking LastPass?

  • 6 odpowiedzi
  • 12 osób ma ten problem
  • 27 wyświetleń
  • Ostatnia odpowiedź od cor-el

more options

About 5-7 days ago, LastPass stopped filling in the forms on websites.

I had to manually select Edit to get to the UN/PW for any account.

LP said that their system did not see LP on my browser and to uninstall and reinstall LP.

I followed their directions and used the link that they gave me to reinstall the addon...

FireFox blocked the addition of the addon

this is the message that I received:

"FireFox prevented this site from asking you to install software on your computer"

I went to FF addons and added LP and it is still not working.

I am using version 45.9 Firefox ESR and I'm informed that "Firefox is up to date"

I use LastPass repeatedly throughout the day and will greatly appreciate a fix for this.

FireFox is my main browser.

Karen

About 5-7 days ago, LastPass stopped filling in the forms on websites. I had to manually select Edit to get to the UN/PW for any account. LP said that their system did not see LP on my browser and to uninstall and reinstall LP. I followed their directions and used the link that they gave me to reinstall the addon... FireFox blocked the addition of the addon this is the message that I received: "FireFox prevented this site from asking you to install software on your computer" I went to FF addons and added LP and it is still not working. I am using version 45.9 Firefox ESR and I'm informed that "Firefox is up to date" I use LastPass repeatedly throughout the day and will greatly appreciate a fix for this. FireFox is my main browser. Karen

Wszystkie odpowiedzi (6)

more options

just in case.. here's the link provided by LastPass to download/install the addon

4. Reinstall LastPass for Firefox https://lastpass.com/lastpassffx/xpi.php

more options

All addons need to be signed by Mozilla (installed from AMO) in order to be installed in Firefox. Mozilla verifies and "signs" add-ons that follow a set of security guidelines. All add-ons hosted on addons.mozilla.org undergo this process in order to be signed. Add-ons hosted on other sites will need to follow the same guidelines in order to be signed by Mozilla. This limitation is not in ESR but is hidden behind a pref in about:config (xpinstall.signatures.required --> false

more options

Thank you for explaining the "what" of this issue

I need to know the "how" as in... how do I fix this problem and get LastPass installed on my FF browsers??

thank you

more options
I need to know the "how" as in... how do I fix this problem and get LastPass installed on my FF browsers??

I did give you instructions on how to enable unsigned addons in ESR (the version you are using based on the user agent supplied by our forum software). If you are running release Firefox (53.0.2) you will not be able to do this as only Beta, Nightly, and ESR can do so.

This limitation is not in ESR but is hidden behind a pref in about:config (xpinstall.signatures.required --> false

Go to about:config via Firefox's address bar, click the warning saying you'll be careful and search at the top of the filter box for xpinstall. and double click the pref and set it to false to allow unsigned addons.

more options

Did you try installing LastPass from the Mozilla Add-ons site?

There are some scathing reviews about the latest version:

https://addons.mozilla.org/firefox/addon/lastpass-password-manager/reviews/

If you prefer to install the immediately previous version, you can find it on the "versions" page here:

https://addons.mozilla.org/firefox/addon/lastpass-password-manager/versions/

Firefox automatically updates extensions when updates are available. To turn that off temporarily for LastPass, go to the Add-ons page:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find LastPass on the right side and click its "More" link. That should show a page with descriptive information about the extension.

Scroll down to the Automatic Updates section and change from Default to Off.

more options

This is not about add-ons needed to be signed if you try to install form the LastPass website. The versions hosted there are signed, but you do not have an install exception that allows to store the extension from this website. In that case save the XPI file to your hard drive (desktop) via the right-click context menu and install the extension locally via the cogwheel button on the about:addons page.