Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Firefox 49.0.2 breaks visual accessiblity by hard-coding white backgorund for add-ons manager and options screen.

  • Nie ma odpowiedzi
  • 1 osoba ma ten problem
  • 6 wyświetleń
more options

Hi Mozilla UI Developers,

You've done this yet again - you've broken visual accessiblity for those with visual impairments who need dark / black backgrounds by hard-coding a white background for the add-ons manager and options screens which is very annoying and disabling.

You fixed this problem when I reported it before. See: <https://support.mozilla.org/en-US/questions/1087155>

.. and now in Firefox 49.0.2 the problem is back. though it could have appeared back in prior versions.

As part of good accessible UI design for folk with visual impairments, by default the application needs to adhere to the Windows System Colours chosen by the user. People with visual accessbility absolutely need and rely on this functionality in Windows - and good applications usually adhere to the central windows system colour settings unless otherwise configured.

Please change the [1] add-on manager screen and [2] options screen to conform by default to the windows system colour settings. So if I have a black background in my Windows System Colour settings - it needs to use that int the various config screens.

I am using a Windows 7 64bit OS with a Classic Theme with the blackground set to black and the text a greenish colour. I'm currently on Firefox 49.0.2. I absolutely need applications to adhere to the system colour scheme so that I can use them and see them comfortably. Most good windows applications do this.

I always use a host of good Firefox add-ons for accessiblity - like Blank Your Monitor - and a number of other Firefox accessiblity tricks - but the background of the add-on manager and options screens are independant to this and stays a bright blindling white - like a bright torchlight shining in your face.

In sort, please stop hard coding white backgrounds into the UI of Firefox - it makes your application inaccessible. You keep on doing this.

Please - I would greatly appreciate it if you would fix this.

Glen

Hi Mozilla UI Developers, You've done this yet again - you've broken visual accessiblity for those with visual impairments who need dark / black backgrounds by hard-coding a white background for the add-ons manager and options screens which is very annoying and disabling. You fixed this problem when I reported it before. See: <https://support.mozilla.org/en-US/questions/1087155> .. and now in Firefox 49.0.2 the problem is back. though it could have appeared back in prior versions. As part of good accessible UI design for folk with visual impairments, by default the application needs to adhere to the Windows System Colours chosen by the user. People with visual accessbility absolutely need and rely on this functionality in Windows - and good applications usually adhere to the central windows system colour settings unless otherwise configured. Please change the [1] add-on manager screen and [2] options screen to conform by default to the windows system colour settings. So if I have a black background in my Windows System Colour settings - it needs to use that int the various config screens. I am using a Windows 7 64bit OS with a Classic Theme with the blackground set to black and the text a greenish colour. I'm currently on Firefox 49.0.2. I absolutely need applications to adhere to the system colour scheme so that I can use them and see them comfortably. Most good windows applications do this. I always use a host of good Firefox add-ons for accessiblity - like Blank Your Monitor - and a number of other Firefox accessiblity tricks - but the background of the add-on manager and options screens are independant to this and stays a bright blindling white - like a bright torchlight shining in your face. In sort, please stop hard coding white backgrounds into the UI of Firefox - it makes your application inaccessible. You keep on doing this. Please - I would greatly appreciate it if you would fix this. Glen

Zmodyfikowany przez nicciglen w dniu