Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Complicated shortcuts do not work with OS X Key remappings.

  • Nie ma odpowiedzi
  • 2 osoby mają ten problem
  • 2 wyświetlenia
more options

Hello,

I've recently moved to Firefox, and would like to figure out if this is an issue just with my install, or for everyone.

My setup is fairly simple, I've got a MacBook Pro running OS X 10.11.5 with the current latest stable release of Firefox (47.0).

The MacBook has its internal keyboard, as well as my main typing keyboard, an external Corsair mechanical keyboard.

The Corsair keyboard was originally designed for Windows, so I remapped some of the OS X key's to better reflect the key mapping of a normal Apple-based Keyboard, settings menu of this can be seen on the first screenshot.

Now that you have some background on my setup, that will likely help, comes the issue. On websites that have multi-key shortcuts, such as CTRL+ALT+S, these shortcuts do not work from the Corsair keyboard at all. I've tried on other site, with only two key shortcuts, such as CTRL+I, and those work fine, just the shortcuts which use two modifier keys and a normal key in conjunction, appear not work at all.

Here's the catch, though, the non working shortcuts work fine on the internal keyboard of the MacBook, which is why I explained my setup in such detail.

Could it be that the use of a PC-keyboard and the modifications of the key's could have something to do with this?

--- Sort of a PS after writing that all- I tried resetting the key mappings to their default on the Corsair keyboard, but it still appears not to work, which is intriguing.

Any ideas?

- Marco

Załączone zrzuty ekranu