Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Unable to print silently in version 46

  • 6 odpowiedzi
  • 4 osoby mają ten problem
  • 9 wyświetleń
  • Ostatnia odpowiedź od bobowen

more options

Since updating to Firefox 46.0, I am unable to print from an Epson Receipt printer. When the "print.always_print_silent" pref. is set to True, the only thing that comes out of the printer is a tiny strip of thermal paper. When the pref. is set to false, it prints just fine. This is affecting multiple locations, all using the Epson TM-T88V. Works fine in other browsers and can downgrade the browser to ver. 45.0.2 and printing works without issue. I have been unable to find anything in about:config that is different between the browser versions that would affect printing. Any assistance would be greatly appreciated.

Since updating to Firefox 46.0, I am unable to print from an Epson Receipt printer. When the "print.always_print_silent" pref. is set to True, the only thing that comes out of the printer is a tiny strip of thermal paper. When the pref. is set to false, it prints just fine. This is affecting multiple locations, all using the Epson TM-T88V. Works fine in other browsers and can downgrade the browser to ver. 45.0.2 and printing works without issue. I have been unable to find anything in about:config that is different between the browser versions that would affect printing. Any assistance would be greatly appreciated.

Wszystkie odpowiedzi (6)

more options

There is a bug report on file for Firefox 47, which use a new technology called Electrolysis or e10s. That feature is currently incompatible with printing silent.

Could you check whether your Firefox is using e10s. Open the support information page using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, toward the bottom, look for a row for "Multiprocess Windows". Does it show a numerator greater than zero?

If so, e10s may be running. Could you check whether this preference was changed:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste remo and pause while the list is filtered

(3) If the browser.tabs.remote.autostart preference is bolded and "user set" to true, double-click it to restore the default value of false

more options

Thank you for your response. Unfortunately, I was unable to find any mention of e10s. The multiprocess Windows shows 0/1 (Disabled) and browser.tabs.remote.autostart is set to False.

More information on this, silent printing does work to a multi-function printer, just not to the receipt printers (EPSON TM-T88V). The unfortunate thing is that Firefox autoupdated in our 300+ locations causing all receipt printing from our web based application to stop since all are configured to use silent printing.

more options

It sounds like a new bug. Why it only affects one kind of printer, I don't know. Perhaps it's something about the paper size. ???

Consider switching your systems to the Extended Support Release version of Firefox 45. See:

https://www.mozilla.org/firefox/organizations/

It should pick up your existing profile folders.

more options

Hi,

Did you manage to work around this problem?

It looks like the issue is an invalid resolution in the prefs, which we now use for printing.

If this was the issue you were hitting, printing with print.always_print_silent=false should set the correct resolution in the prefs and then it should work with print.always_print_silent=true.

A fix is also being applied to prevent the invalid value from the prefs being used in future.

Thanks for reporting this.

more options

Thanks for the information guys.

Our fix was to push out Firefox 45 ESR which we really should've done from the beginning, we just didn't know about it.

The resolution could certainly be an issue as we were attempting to print on 88mm thermal receipt paper. Unfortunately, switching the print.always_print_silent pref between true and false did not resolve the issue. When set to false, printing was unaffected. When set to to true, all we would get was a tiny strip of thermal paper ejected from the printer. Let me know if I can provide anymore information.

more options

Thanks for getting back to me.

Yes, regardless of this problem ESR sounds like the right solution for your situation.

However, I still want to make sure I've fixed this issue and the fact that flipping the pref doesn't work, means I don't understand it fully yet.

I've downloaded the driver for this printer so I can see the communication between Firefox and it and the only difference I can find between 45.0.2 and 46 is this resolution problem. The exact page size we print to internally is slightly different, but given that it prints correctly with the pref disabled, it can't be that.

Is it possible that you have the pref print.save_print_settings set to false? That would explain why flipping the pref, doesn't fix it.

Also, would you be open to testing any fixes in our Nightly build, once they have landed? As I don't have access to one of these printers, that would be really useful.

Apologies for the inconvenience caused by this.