Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

SOLVED: Firefox does search on valid web address containing hyphens and fails to open page as result

  • 3 odpowiedzi
  • 1 osoba ma ten problem
  • 25 wyświetleń
  • Ostatnia odpowiedź od CharlesBird

more options

I have a static website (lets call it foobar.com) hosted on Amazon S3. As it is currently in test, and the DNS is not configured, I am using Amazon end points to connect, and because I will be using SSL in future, the buckets are specified using hyphens. It is configured to redirect requests for www-foobar-com to foobar-com.

If I enter "foobar-com.s3-website-eu-west-1.amazonaws.com/", I get the expected website using firefox 45.0.1 on win7

But if I enter "www-foobar-com.s3-website-eu-west-1.amazonaws.com" or "http://www-foobar-com.s3-website-eu-west-1.amazonaws.com", firefox doesn't open the webpage, but instead looks up the address, decides I meant "www.foobar.com" and fails to open (the non-existent) www.foobar.com

IE and Chrome have no problem opening the "www-foobar-com." address

It looks like the initial www is confusing the search in address bar functionality

Zmodyfikowany przez CharlesBird w dniu

Wybrane rozwiązanie

Looks like a caching problem - I'd tried to access the www- page with firefox before the permissions were correctly set and it seems to have "remembered" the failure

Working OK with a couple of new test cases this morning

Thanks for your suggestions

Przeczytaj tę odpowiedź w całym kontekście 👍 2

Wszystkie odpowiedzi (3)

more options

Does it make any difference if you disable the fixup function?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fix and pause while the list is filtered

(3) Double-click the browser.fixup.alternate.enabled preference to switch it from true to false

If it's not fixup, there may be a problem with the DNS bits. Probably would make sense to file a bug in that case to see what they make of it on the development end.

https://bugzilla.mozilla.org/enter_bug.cgi

more options

I'm not getting a search page with the URL you posted.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button/Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

See also:

Zmodyfikowany przez cor-el w dniu

more options

Wybrane rozwiązanie

Looks like a caching problem - I'd tried to access the www- page with firefox before the permissions were correctly set and it seems to have "remembered" the failure

Working OK with a couple of new test cases this morning

Thanks for your suggestions