Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Text with the letters of NO and TM sometimes display them as superscript.

  • 2 odpowiedzi
  • 3 osoby mają ten problem
  • 18 wyświetleń
  • Ostatnia odpowiedź od scottyanke

more options

On some web pages, words that start with the letters NO or include TM have part of the word displayed as superscripted. For example, if the sentance starts with the word None, then the No part of the word has the o raised and underlined like it is an abbreviation for the word number. A part number like STM32F103 will have the letters TM raised as if it were an abbreviation for the word trademark.

I've tried setting different fonts, and found that specifically setting a font while not allowing the site to override it avoids the problem. Unfortunately some sites use characters that I just can't identify, so I normally run with the option to allow pages to choose their own fonts, instead of using fixed fonts.

On ebay, for one example, I have the problem with the superscripted characters. I've tried using Google Chrome as a comparison, and have found that the pages display correctly with Chrome but not with Firefox. Doing a Google or Yahoo search gives me a results page that does not have the superscripted characters.

Is there something I am missing in the configuration of Firefox that is causing this? I kind of need the sites to select their own fonts, because otherwise I end up with some very odd looking pages (even stranger than having NO or TM displayed wrong).

On some web pages, words that start with the letters NO or include TM have part of the word displayed as superscripted. For example, if the sentance starts with the word None, then the No part of the word has the o raised and underlined like it is an abbreviation for the word number. A part number like STM32F103 will have the letters TM raised as if it were an abbreviation for the word trademark. I've tried setting different fonts, and found that specifically setting a font while not allowing the site to override it avoids the problem. Unfortunately some sites use characters that I just can't identify, so I normally run with the option to allow pages to choose their own fonts, instead of using fixed fonts. On ebay, for one example, I have the problem with the superscripted characters. I've tried using Google Chrome as a comparison, and have found that the pages display correctly with Chrome but not with Firefox. Doing a Google or Yahoo search gives me a results page that does not have the superscripted characters. Is there something I am missing in the configuration of Firefox that is causing this? I kind of need the sites to select their own fonts, because otherwise I end up with some very odd looking pages (even stranger than having NO or TM displayed wrong).

Wybrane rozwiązanie

What font is used for those characters?

You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer).

  • You can check the font used for selected text in the Font tab in the right pane of the Inspector.

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Edit > Preferences > Content Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

You can do a font test to see if you can identify not working font(s).

Przeczytaj tę odpowiedź w całym kontekście 👍 0

Wszystkie odpowiedzi (2)

more options

Wybrane rozwiązanie

What font is used for those characters?

You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer).

  • You can check the font used for selected text in the Font tab in the right pane of the Inspector.

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Edit > Preferences > Content Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

You can do a font test to see if you can identify not working font(s).

more options

Using the inspector helped. What it showed me was that the Nimbus Sans L font was being used. While I had that font in the default/Type1 directory of /usr/share/fonts, it turns out that I also had a copy of that font (from somewhere) in my local ~/.fonts directory. Deleting the extra copy of the font corrected that problem.

To help me with that I used the fc-list utility and grepped it to the Nimbus font. It pointed me to the local .fonts directory for that specific font. All other fonts appeared in the /usr/share/fonts directory. I didn't even realize I had setup a local font back in 2012...

Thank you for pointing out to use the inspector. It gave me the information to duplicate the font problem with both Thunderbird and Libre Writer.