Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

FF29.0.1: Get Add-Ons webpage must load before I can view my Extensions?

  • 6 odpowiedzi
  • 1 osoba ma ten problem
  • 1 wyświetlenie
  • Ostatnia odpowiedź od the-edmeister

more options

With FF29.0.1, every time I go to about:addons, I can't access anything on that page (Extensions, Appearance, Plugins) until the Get Add-Ons page fully loads. This is baffling behavior; why would I need a webpage (that I don't usually care to read) to finish loading before I can access the list of my locally-installed Extensions? And it's not like the server that hosts the webpage is the fastest thing, either; it takes up to 20 seconds for the page to load, 20 seconds I spend staring at a half-loaded page, twiddling my thumbs. Mozilla, please fix this ASAP; it's just bad UI design.

Wszystkie odpowiedzi (6)

more options

The page is locked until it is loaded. Don't worry, just wait a few seconds.

more options

"A few seconds" being 20 or so. It's not something I'd really like to do on a regular basis, especially if I'm repeatedly disabling extensions and restarting in order to find a misbehaving one. Is there any way to stop the Get Add-Ons page from being the default view, i.e. to have it default to the Extensions instead when I load about:addons? Because as I've mentioned above, I really don't care to read the page in the first place; I normally go to about:addons to configure add-ons, not to download new ones.

EDIT: For what it's worth, I've found that the page load time for the Get Add-Ons page is significantly reduced if I disable a misbehaving userscript. Still doesn't solve the fundamental problem of not wanting to wait for a webpage to load if all I want to do is to access local files.

Zmodyfikowany przez user885311 w dniu

more options

I have several add-ons that put extra information and options on my page. But even with that, I only take about 5 seconds.

Many site issues can be caused by corrupt cookies or cache.

Clear the Cache
Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

Remove Cookies
Firefox/Tools > Options > Privacy.
Under History, select Firefox will Use Custom Settings.
There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration.
Poke around safe web sites and see if there is still a problem. Then restart.

more options

It should open at the last panel that was open when you closed the Add-ons manager.

Setting the extensions.getAddons.showPane preference to false in about:config used to hide it in past.

more options

Hm, that option seems to have been removed. Thanks, though, for the tip.

more options

Put this code in a userContent.css file that you create to block Get Add-ons from showing.
http://kb.mozillazine.org/UserContent.css

 @-moz-document url("about:addons") {
#category-discover { display:none!important; }
}

You can install this extension - http://webdesigns.ms11.net/chromeditp.html - which creates the "3 user files" and provides an editing window within Firefox.