Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I turn off the "Awesome Bar" entirely. I do not want this feature at all.

  • 6 svar
  • 1 har dette problemet
  • 68 views
  • Siste svar av bettyford

more options

I WANT an address bar. I DO NOT WANT an "Awesome Bar". In prior versions of FF, I was able to NOT SEARCH from the address bar. Now [FF 24 vs. FF 17] I can not turn off this rather unwanted behavior.

Valgt løsning

I have resolved the issue... There was a misbehaving "key" left over from installation and removal of a search engine toolbar. The tag has been removed from "about:config", and the expected browser behavior has returned. It would seem that perhaps some of the "key" tags have been renamed since my last version - which may explain why the errant behavior began with a browser update.

EDIT: BTW - The "Nothing" setting should be a priorty setting which is not able to be changed by any other means. It should be set to override all other behavior. Also, it would be nice to have a visual sense that the urlbar searching is turned off - by toggling the default text listed in a "blank" address bar... from "search or enter address" to "enter address / searching off"

Les dette svaret i sammenhengen 👍 0

All Replies (6)

more options
more options

Nope. This does not turn off the Awesome bar. It simply turns off a few items related to it. If I type the letters 'fg' in the address bar, it still comes up with wikipedia entries. I do not wish anything to come up. There is still a setting for display options "Nothing" in the preferences, but that apparently now does "Nothing"

more options

are those wikipedia entries coming from you history/bookmarks? otherwise have a look into your installed extensions - maybe one of them is adding this search functionality...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Nope. I have history turned off. I have private browsing turned on. I have "Nothing" selected as suggestions for location bar. I have my cache to clear on exit. I can shutdown the browser, restart, type only the letters 'fg' in the location bar - and get wikipedia entries...

After searching through FF config wiki - I have located the urlbar options - setting all boolean options to "false" does not prevent the urlbar from activating its search abilities...

more options

can you provide a screenshot of the issue?

more options

Valgt løsning

I have resolved the issue... There was a misbehaving "key" left over from installation and removal of a search engine toolbar. The tag has been removed from "about:config", and the expected browser behavior has returned. It would seem that perhaps some of the "key" tags have been renamed since my last version - which may explain why the errant behavior began with a browser update.

EDIT: BTW - The "Nothing" setting should be a priorty setting which is not able to be changed by any other means. It should be set to override all other behavior. Also, it would be nice to have a visual sense that the urlbar searching is turned off - by toggling the default text listed in a "blank" address bar... from "search or enter address" to "enter address / searching off"

Endret av bettyford