X
Trykk her for å gå til den mobile utgaven av nettstedet.

Brukerstøtteforum

После обновления до версии 13.0.1 возникли проблемы с изображением НЕКОТОРЫХ слов на кириллице на русскоязычных сайтах

Skrevet

Вместо букв - пресловутые квадратики. В основном это имеет место в заглавиях текстовых параграфов. Основной текст нормальныйю Пробовал менять кодировки. Пробовал по совету, найденному здесь, очищать кэш. Смотрел строку "network.http.accept-encoding: gzip,deflate" (тоже по местному совету).

Вместо букв - пресловутые квадратики. В основном это имеет место в заглавиях текстовых параграфов. Основной текст нормальныйю Пробовал менять кодировки. Пробовал по совету, найденному здесь, очищать кэш. Смотрел строку "network.http.accept-encoding: gzip,deflate" (тоже по местному совету).

Valgt løsning

You seem to having problem with text that has a font-weight:700 The font-family is specified as Arial,Helvetica,sans-serif

You can copy and paste this test code in the location bar to see if it has the same problem.


data:text/html;charset=utf-8,<html><head></head><body><b>Arial,Helvetica,sans-serif;25px;normal;700;normal;normal;?0x400;0x52f</b><p style='font-family:Arial,Helvetica,sans-serif; font-size:25px; font-weight:700'>ЀЁЂЃЄЅІЇЈЉЊЋЌЍЎЏАБВГДЕЖЗИЙКЛМНОП<br>РСТУФХЦЧШЩЪЫЬЭЮЯабвгдежзийклмноп<br>рстуфхцчшщъыьэюяѐёђѓєѕіїјљњћќѝўџ<br>ѠѡѢѣѤѥѦѧѨѩѪѫѬѭѮѯѰѱѲѳѴѵѶѷѸѹѺѻѼѽѾѿ<br>Ҁҁ҂҃҄҅҆҇҈҉ҊҋҌҍҎҏҐґҒғҔҕҖҗҘҙҚқҜҝҞҟ<br>ҠҡҢңҤҥҦҧҨҩҪҫҬҭҮүҰұҲҳҴҵҶҷҸҹҺһҼҽҾҿ<br>ӀӁӂӃӄӅӆӇӈӉӊӋӌӍӎӏӐӑӒӓӔӕӖӗӘәӚӛӜӝӞӟ<br>ӠӡӢӣӤӥӦӧӨөӪӫӬӭӮӯӰӱӲӳӴӵӶӷӸӹӺӻӼӽӾӿ<br>ԀԁԂԃԄԅԆԇԈԉԊԋԌԍԎԏԐԑԒԓԔԕԖԗԘԙԚԛԜԝԞԟ<br>ԠԡԢԣԤԥԦԧԨԩԪԫԬԭԮ<br></p></body></html>

You can use this extension to see which fonts are used for selected text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and disable website fonts as a test.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
Les dette svaret i sammenhengen 1

Flere systemdetaljer

Dette skjedde

Hver gang Firefox åpnes

Dette begynte å skje når ...

After I have updated Firefox to 13.0.1 version

Installerte programtillegg

Adobe Acrobat, Microsoft DRM, Quick time, Real Jukebox NS, RealOne Player, RealPlayer G2 LiveConnect, Shockwave Flash, Shockwave for director, Windows Media Player DLL

Applikasjon

  • Brukeragent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322)

Mer informasjon

philipp
  • Top 25 Contributor
  • Moderator
5330 løsninger 23532 svar

Hjelpsomt svar

hello lav123, please also try to right click and reset all other preferences that start with "network.http." if they are set to a custom value & displayed in bold text at the moment.

hello lav123, please also try to right click and reset all other preferences that start with "network.http." if they are set to a custom value & displayed in bold text at the moment.

Eieren av spørsmålet

Hello madperson. Thanks for the reply. I have checked again - all my "network.http." lines are set to default value.

Hello madperson. Thanks for the reply. I have checked again - all my "network.http." lines are set to default value.
cor-el
  • Top 10 Contributor
  • Moderator
17670 løsninger 159848 svar

Can you attach a screenshot if your problem isn't solved?

Use a compressed image type like PNG or JPG to save the screenshot.

This usually indicates that there is a problem with the font if you see little square boxes with the hex code instead of the character.

Can you attach a screenshot if your problem isn't solved? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot. This usually indicates that there is a problem with the font if you see little square boxes with the hex code instead of the character.

Eieren av spørsmålet

Hello cor-el. Thanks for the reply. Please, find attached the screenshot.

P.S. There is no such a problem when I use IE.

Hello cor-el. Thanks for the reply. Please, find attached the screenshot. P.S. There is no such a problem when I use IE.
cor-el
  • Top 10 Contributor
  • Moderator
17670 løsninger 159848 svar

Valgt løsning

You seem to having problem with text that has a font-weight:700 The font-family is specified as Arial,Helvetica,sans-serif

You can copy and paste this test code in the location bar to see if it has the same problem.


data:text/html;charset=utf-8,<html><head></head><body><b>Arial,Helvetica,sans-serif;25px;normal;700;normal;normal;?0x400;0x52f</b><p style='font-family:Arial,Helvetica,sans-serif; font-size:25px; font-weight:700'>ЀЁЂЃЄЅІЇЈЉЊЋЌЍЎЏАБВГДЕЖЗИЙКЛМНОП<br>РСТУФХЦЧШЩЪЫЬЭЮЯабвгдежзийклмноп<br>рстуфхцчшщъыьэюяѐёђѓєѕіїјљњћќѝўџ<br>ѠѡѢѣѤѥѦѧѨѩѪѫѬѭѮѯѰѱѲѳѴѵѶѷѸѹѺѻѼѽѾѿ<br>Ҁҁ҂҃҄҅҆҇҈҉ҊҋҌҍҎҏҐґҒғҔҕҖҗҘҙҚқҜҝҞҟ<br>ҠҡҢңҤҥҦҧҨҩҪҫҬҭҮүҰұҲҳҴҵҶҷҸҹҺһҼҽҾҿ<br>ӀӁӂӃӄӅӆӇӈӉӊӋӌӍӎӏӐӑӒӓӔӕӖӗӘәӚӛӜӝӞӟ<br>ӠӡӢӣӤӥӦӧӨөӪӫӬӭӮӯӰӱӲӳӴӵӶӷӸӹӺӻӼӽӾӿ<br>ԀԁԂԃԄԅԆԇԈԉԊԋԌԍԎԏԐԑԒԓԔԕԖԗԘԙԚԛԜԝԞԟ<br>ԠԡԢԣԤԥԦԧԨԩԪԫԬԭԮ<br></p></body></html>

You can use this extension to see which fonts are used for selected text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and disable website fonts as a test.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
You seem to having problem with text that has a font-weight:700 The font-family is specified as Arial,Helvetica,sans-serif You can copy and paste this test code in the location bar to see if it has the same problem. ---- <pre><nowiki>data:text/html;charset=utf-8,<html><head></head><body><b>Arial,Helvetica,sans-serif;25px;normal;700;normal;normal;?0x400;0x52f</b><p style='font-family:Arial,Helvetica,sans-serif; font-size:25px; font-weight:700'>ЀЁЂЃЄЅІЇЈЉЊЋЌЍЎЏАБВГДЕЖЗИЙКЛМНОП<br>РСТУФХЦЧШЩЪЫЬЭЮЯабвгдежзийклмноп<br>рстуфхцчшщъыьэюяѐёђѓєѕіїјљњћќѝўџ<br>ѠѡѢѣѤѥѦѧѨѩѪѫѬѭѮѯѰѱѲѳѴѵѶѷѸѹѺѻѼѽѾѿ<br>Ҁҁ҂҃҄҅҆҇҈҉ҊҋҌҍҎҏҐґҒғҔҕҖҗҘҙҚқҜҝҞҟ<br>ҠҡҢңҤҥҦҧҨҩҪҫҬҭҮүҰұҲҳҴҵҶҷҸҹҺһҼҽҾҿ<br>ӀӁӂӃӄӅӆӇӈӉӊӋӌӍӎӏӐӑӒӓӔӕӖӗӘәӚӛӜӝӞӟ<br>ӠӡӢӣӤӥӦӧӨөӪӫӬӭӮӯӰӱӲӳӴӵӶӷӸӹӺӻӼӽӾӿ<br>ԀԁԂԃԄԅԆԇԈԉԊԋԌԍԎԏԐԑԒԓԔԕԖԗԘԙԚԛԜԝԞԟ<br>ԠԡԢԣԤԥԦԧԨԩԪԫԬԭԮ<br></p></body></html></nowiki></pre> ---- You can use this extension to see which fonts are used for selected text. *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/ You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and disable website fonts as a test. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"

Eieren av spørsmålet

Thank you for the information above. It turned out that the squares appear if Times New Roman or Arial are used on a site. Both bold and normal. I haven't analysed what size or other parameters of the fonts cause the squares appearance. I have tried changing the fonts of pages to MS Sans Serif, Courier New - No squares! Thank you very much for you detailed advice! It has helped to solve the problem of reading sites. The reason of the problem, I think, - the last version of FireFox. I don't think that my Times New Roman or Arial are corrupted. IE, MS Word, etc. show them correctly. Obviously, something went wrong in the newest FireFox. So, we'll wait for next updates. Thanks a lot again.

Thank you for the information above. It turned out that the squares appear if Times New Roman or Arial are used on a site. Both bold and normal. I haven't analysed what size or other parameters of the fonts cause the squares appearance. I have tried changing the fonts of pages to MS Sans Serif, Courier New - No squares! Thank you very much for you detailed advice! It has helped to solve the problem of reading sites. The reason of the problem, I think, - the last version of FireFox. I don't think that my Times New Roman or Arial are corrupted. IE, MS Word, etc. show them correctly. Obviously, something went wrong in the newest FireFox. So, we'll wait for next updates. Thanks a lot again.
cor-el
  • Top 10 Contributor
  • Moderator
17670 løsninger 159848 svar

You're welcome

You're welcome