Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error code: sec_error_untrusted_issuer, after i add the exception, get the certificate i get a blank page with big letters NOT FOUND.

  • Ingen svar
  • 54 har dette problemet
  • 1 view
more options

www.google.com uses an invalid security certificate.

The certificate is not trusted because it is self-signed. The certificate is only valid for 78-159-121-201.local

(Error code: sec_error_untrusted_issuer)

After i add an exception for the site, i get this: Certificate Status: This site attempts to identif itself with invalid information.

Wrong site: Certificate belongs to a diffrent site, which could indicate an identity theft.

Unknown Identity

Certificate is not trusted, because it hasn't been verified by a recognized authority.

And then a blank page with big letters "Not Found"

URL of affected sites

http://google.com , www.youtube.com , www.omegle.com , www.lockerz.com

All Replies (2)

more options

Do NOT add a security exception: someone is tampering with your internet connection!

When you ask to connect to these sites using https, Firefox gets a certificate from the website which responds. Anyone can make a certificate, but to be valid the certificate must be signed by an organization which Firefox trusts.

The person responding provided a certificate with its response which which was not signed by anybody, so Firefox doesn't know who sent the response, and neither do you.

In short: you asked to talk to google and google did NOT send the response.

As this is happening for several different websites, the attacker is probably on the network between your computer and the internet. Ask the people you get your internet connection for help: they may have had their computers hacked, may discover that the problem exists further along in the network, or they may even be responsible themselves.

more options

Check the connection settings to make sure that you do not use a proxy.

  • Tools > Options > Advanced : Network : Connection

See "Firefox connection settings":