Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

exceptions in configuration security disappear after restart

more options

I have a NAS server, where I save all my data. When I type the local address 192.168.2.10:5001 I always get the warning That this is a malicious site. I havo enter I know the risk etc. which cost me time and is useless, since my NAS server is under my control.

I have tried to put the server address in several exceptions, but they disappear.

How to tell Firefox that my Nas srver is safe?

I have a NAS server, where I save all my data. When I type the local address 192.168.2.10:5001 I always get the warning That this is a malicious site. I havo enter I know the risk etc. which cost me time and is useless, since my NAS server is under my control. I have tried to put the server address in several exceptions, but they disappear. How to tell Firefox that my Nas srver is safe?

All Replies (2)

more options

This could be about a new security feature that blocks unsafe downloads, but can interfere with downloading files. You can set dom.block_download_insecure => false in about:config to disable this feature.

Helpful?

more options

Hi Raymond, I assume this is a verification issue like certificate issuer not recognized and not the red warning page shown when a site is considered malicious based on Google SafeBrowsing data. If you could copy/paste the text of the error page into a reply (here on the forum, not by email), that would be helpful.

Normally if you go through the Accept button and then click Accept the Risk and Continue, the site certificate is saved permanently (in the cert9.db file in your Firefox profile). You should be able to see it on the Settings page:

  • Open the Settings page
  • Slowly type cert in the tiny search box until Firefox brings the View Certificates... button into view
  • Click the "View Certificates..." button to open the Certificate Manager dialog
  • Change to the Servers list -- do you see your exception(s) saved here?

Firefox might not save the certificate permanently if (A) you are using a private window, or (B) you set security.certerrors.permanentOverride to false in about:config.

Helpful?

Still et spørsmål

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.