Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google pages (Gmail, YouTube, etc.) won't load if I am using VPN (PIA)

more options

I am using Firefox with the uBlock Origin and Cookie AutoDelete extensions enabled. When I try and load Gmail or any other Google site, I get a blank page and nothing loads at all. This only occurs when my VPN is on (I use Private Internet Access). However, even with the VPN on, Chrome will still load those sites. Disabling the VPN means that the sites load normally.

My guess is it might be some sort of privacy setting in Firefox, but I don't understand what it could be. The only thing that breaks/fixes the sites is connecting and disconnecting the VPN, irrespective of which country I try and connect from.

I am using Firefox with the uBlock Origin and Cookie AutoDelete extensions enabled. When I try and load Gmail or any other Google site, I get a blank page and nothing loads at all. This only occurs when my VPN is on (I use Private Internet Access). However, even with the VPN on, Chrome will still load those sites. Disabling the VPN means that the sites load normally. My guess is it might be some sort of privacy setting in Firefox, but I don't understand what it could be. The only thing that breaks/fixes the sites is connecting and disconnecting the VPN, irrespective of which country I try and connect from.

Valgt løsning

I ended up resolving it based partly on the solution found here. TLDR: I had to change the VPN DNS settings.

I noticed that the DNS setting on my home WiFi was not stable; if the issue was coming from inconsistent DNS servers then this would not help. I deleted the default DNS servers and added a public one (OpenDNS... don't really know if some are better than others). Then I changed the PIA settings (have to do this in the desktop app itself) to "Use Existing DNS" . Setting it to "Custom" and pasting in the same DNS as I had just set in my computer's WiFi preferences did work too, mostly, but for some reason I kept getting an endless string of Captcha if I tried using Google services.

I don't know enough about why this occurred only while using Firefox to comment on that, but FWIW it does seem like DNS settings and inconsistencies matter with this browser in a way that they didn't for others, in this case at least.

Thanks all for your input.

Les dette svaret i sammenhengen 👍 0

All Replies (7)

more options
  • A quick additional detail: when I use my work VPN, Google sites load normally as well. So it seems the problem is with PIA... ?

Helpful?

more options

Minimal Gravitas said

When I try and load Gmail or any other Google site, I get a blank page and nothing loads at all. This only occurs when my VPN is on (I use Private Internet Access).

Sounds like a VPN issue to me. To test it, just open Firefox in Safe Mode see if you still have the same issue.

Helpful?

more options

Try clearing site cookies and disabling Tracking Protection for the site.

Does it still happen in Troubleshoot Mode?

Helpful?

more options

jonzn4SUSE said

Minimal Gravitas said

When I try and load Gmail or any other Google site, I get a blank page and nothing loads at all. This only occurs when my VPN is on (I use Private Internet Access).

Sounds like a VPN issue to me. To test it, just open Firefox in Safe Mode see if you still have the same issue.

Thanks for getting back. I did open it in Safe Mode and had the same issue - this you would assume means it is a VPN issue, not Firefox? (But why does it work in other browsers? Surely these sites aren't only refusing to function for the combination PIA+Firefox and not PIA+Chrome or PIA+Opera...?)

Helpful?

more options

zeroknight said

Try clearing site cookies and disabling Tracking Protection for the site. Does it still happen in Troubleshoot Mode?

Hi, thanks for replying. Yes, the situation persisted after I backed up my account, removed my profile, opened in Troubleshoot mode, refreshed Firefox, re-installed Firefox... everything I could think of to get the most vanilla, out-of-the-box Firefox experience.

I would be ready to believe it is just a VPN issue except... why is Firefox the only browser that is failing here?

Helpful?

more options

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data => false on the about:config page to disable this feature.

See also:

Helpful?

more options

Valgt løsning

I ended up resolving it based partly on the solution found here. TLDR: I had to change the VPN DNS settings.

I noticed that the DNS setting on my home WiFi was not stable; if the issue was coming from inconsistent DNS servers then this would not help. I deleted the default DNS servers and added a public one (OpenDNS... don't really know if some are better than others). Then I changed the PIA settings (have to do this in the desktop app itself) to "Use Existing DNS" . Setting it to "Custom" and pasting in the same DNS as I had just set in my computer's WiFi preferences did work too, mostly, but for some reason I kept getting an endless string of Captcha if I tried using Google services.

I don't know enough about why this occurred only while using Firefox to comment on that, but FWIW it does seem like DNS settings and inconsistencies matter with this browser in a way that they didn't for others, in this case at least.

Thanks all for your input.

Helpful?

Still et spørsmål

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.