Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox always sets address to https

  • 4 svar
  • 0 har dette problemet
  • 26 views
  • Siste svar av zeroknight

more options

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution.

https only mode is not active

browser.fixup.alternate.protocol is set to http from https browser.urlbar.autoFill is set to false

Nothing helped.

I get that this default makes sense but since so many local tools don't use http there should be at least 1 working option to disable this behavior at least for certain sites.

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution. https only mode is not active browser.fixup.alternate.protocol is set to http from https browser.urlbar.autoFill is set to false Nothing helped. I get that this default makes sense but since so many local tools don't use http there should be at least 1 working option to disable this behavior at least for certain sites.

Valgt løsning

Try setting the following preference in about:config to false. browser.fixup.fallback-to-https

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Les dette svaret i sammenhengen 👍 1

All Replies (4)

more options

Valgt løsning

Try setting the following preference in about:config to false. browser.fixup.fallback-to-https

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Helpful?

more options

If it is falling back to https then the http server is not accessible.

Helpful?

more options

browser.fixup.fallback-to-https

Was the solution.

Yes, it only falls back if the server is not reachable. At that moment. For every retry it will be annoying in a situation where something is already not working. And that's the best case where you can rely on that knowledge that the http site is actually not reachable.

Still give it a helpful rating because that best case is better then my situation before.

For some reason voting the answer helpful doesn't work, are there any new user quotas in place or something like that?

Endret av danielw90.dw+firefox

Helpful?

more options

Disabling browser.fixup.fallback-to-https may stop some sites from working though. Better to leave it enabled and be mindful of the protocol when accessing known HTTP services. You can bookmark the site to make retrying easier.

Helpful?

Still et spørsmål

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.