Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Menu Languages are mixed

  • 2 svar
  • 1 har dette problemet
  • 1 view
  • Siste svar av cor-el

more options

Hi, Some Menu and context items are in German even though everything is set to English and it driving me nuts.... see picture. How do I force Firefox to be in English?

Windows 10 Display language is English (US), preferred language is English US, location is Germany. Firefox is version 80 and in Settings General Language is set to English US.

Hi, Some Menu and context items are in German even though everything is set to English and it driving me nuts.... see picture. How do I force Firefox to be in English? Windows 10 Display language is English (US), preferred language is English US, location is Germany. Firefox is version 80 and in Settings General Language is set to English US.
Attached screenshots

Valgt løsning

Go to about:support and Try clearing the startup cache, using the top right button.

Les dette svaret i sammenhengen 👍 1

All Replies (2)

more options

Valgt løsning

Go to about:support and Try clearing the startup cache, using the top right button.

more options

Note that you can install the en-US Firefox version to avoid (mixed) language issues.

You can find the full version of the current Firefox release (809.0) in all languages and all operating systems here: