Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has a white border around the fullscreen window when in 4k

  • 4 svar
  • 2 har dette problemet
  • 3 views
  • Siste svar av Pavlos92

more options

Just bought a 4k monitor and there is a visible white border around ever side but the top border. Chrome is normal and any other window like Steam and Spotify is fine. My windows scaling is at recommended 150% but at 100% its not there anymore. I cant use that though as everything is tiny. Ive tried things like changing the colour intensity on windows and adding stuff to the userchrome but nothing seems to work. Ive gone back to using chrome for now as i cant use firefox with that border. Is there any way to fix it?

All Replies (4)

more options

Windows scaling depends on the GPU and O/S interface. Did you update the GPU software to work with the 4k monitor and did it list the right monitor for the GPU?

Endret av WestEnd

more options

You can try to rename/remove xulstore.json and if present delete localstore.rdf in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

cor-el said

You can try to rename/remove xulstore.json and if present delete localstore.rdf in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. You can try to disable hardware acceleration in Firefox. Close and restart Firefox after modifying the setting for changes to take effect. You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

I went through all that and the issue seems to still persist. It seems to be that the windows scaling is messing up the firefox borders or something like that as ive never seen it before.

Endret av Pavlos92

more options

WestEnd said

Windows scaling depends on the GPU and O/S interface. Did you update the GPU software to work with the 4k monitor and did it list the right monitor for the GPU?

I have a 1080 and it seems to be on the latest driver so i think windows scaling is somehow making the firefox borders not right. My other monitor is a 1440p one and thats on 100% scaling with no border but if i put it to 150% like the 4k monitor then the border appears.