Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

e10s is not being enabled due to plugins, even though all plugins are disabled

  • 4 svar
  • 1 har dette problemet
  • 9 views
  • Siste svar av cor-el

more options

Hello,

I'm running Firefox and am experiencing issues regarding the new e10s (Electrolysis), multi-process windows feature. The feature just doesn't enable. The 'about:support' page mentioned that it's disabled by add-ons.

https://u.visee.me/public/firefox-e10s-not-enabling.png

Now, that's fine and all. The problem is, that this is still showing up when I'm disabling all add-ons. The feature doesn't enable, neither does it when fully restarting the browser. Weird. Restarting Firefox in safe-mode (with all add-ons disabled) doesn't solve the issue either.

I've installed an add-on to test the compatibility with e10s of all plugins, and did disable just the add-ons that might be causing trouble. But that wasn't helpful either.

What is going on, and how can I enable e10s without forcing it in 'about:config'? Also, is there a better way, to get a more detailed summary of why e10s isn't being enabled?

Additional information: Firefox: 54.0 64-bit (from the Canonical repository) Operating system: Ubuntu 17.04 64-bit

Thanks, Tim Visée, https://timvisee.com/

All Replies (4)

more options

Although the Troubleshooting Information page uses the ambiguous term "Add-ons" it is in fact Extensions which are the issue.

Some releases of Firefox have taken a maximum caution route and didn't enable e10s with ANY extensions. I don't recall whether that has been relaxed in Firefox 54, but since it is the first version that is going to four content processes, perhaps it's still going slow on assuming compatibility.

Which is all to say, you might need to force it if you want to try it.

more options

Thank you for your answer.

There are indeed a few extensions installed, and I might try to remove these as you can't disable them in the browser itself.

I did assume though that that using safe mode would disable these extensions too.

I'll give an instance with no extensions a try.

Thanks, Tim Visée

more options

timvisee said

I did assume though that that using safe mode would disable these extensions too.

You're right,   Safe Mode disables all add-ons.

'Add-ons' is the collective name for extensions, themes and plugins.


Should you decide to force-enable Multi-process :

(I recommend that you backup your user profile before you do)

1. Type   about:config   in the address bar and press Enter. 2. Right-click and select New => Boolean. 3. Name it :   browser.tabs.remote.force-enable 4. Set its value to   true


You could give this a try first :

Type in the address bar about:config (promise to be careful, if asked) Type and search for the preferences :

browser.tabs.remote.autostart and set it's value to true   (default is   false) browser.tabs.remote.autostart.2 and set it's value to true

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

more options

Note that this might be about extensions that your Ubuntu Firefox version from the repositories ads to Firefox. These extensions are likely installed globally and can't be removed other than removing them from its install location.

You can find the install location in the extensions.json file. You can open the extensions.json file in the Scratchpad and search for this extension. The descriptor field lists the install location of an extension.